Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just recently installed RHEL 5 on a virtual machine. The server is set up to use a static IP, which I've configured in the Network Configuration GUI. There is only ethernet interface set up called eth0 which is set to activate on boot. After restarting Linux, I went to check to make sure that it was indeed activated, but it wasn't so I manually activated the device.

Going into the command line, I tried:

  • Iinging but got 100% packet loss.
  • Pinged the IP address of the router the server is using for the gateway (set in Network Configuration Manager), which came back with 0% packet loss.
  • I tried pinging the IP address of the server itself, which again came back with 0% packet loss.

However, if I try opening up Firefox and navigating to a site, nothing will come up. Any suggestions?

UPDATE 1: When I ping, I don't get "Unknown host", so the DNS should be fine.

Following Matt's advice, I issued the command route -n and got the following output:

> Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.X.X.0   U     0      0        0 eth0     U     0      0        0 eth0         10.X.X.1         UG    0      0        0 eth0

UPDATE 2: After issuing the command:

traceroute -n

I am seeing IP addresses for #1 and #2, but the rest of them have three asterisks where the IP addresses should be. Plus, I couldn't even connect to using the telnet command. So it does look like a network firewall is most likely causing the problem. I think that's about all the information I can provide until I can confirm whether or not the cause is indeed a firewall.

share|improve this question
updated my answer with new info – Matt Simmons Aug 10 '09 at 19:23
up vote 2 down vote accepted

When you ping, did it resolve? In other words, did it come up and say

 msimmons@newcastle:~$ ping
 PING ( 56(84) bytes of data.

Or did it say

 ping: unknown host

Assuming it said the first, your DNS is fine. At that point, lets look into the routing:

Here's mine:

 msimmons@newcastle:~$ route -n
 Kernel IP routing table
 Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
 10.x.x.0   U     0      0        0 eth0         10.x.x.1         UG    0      0        0 eth0

Since I'm on an internal network, everything destined for 10.x.x.0/24 (the /24 comes from the "genmask" column) goes out the local ethernet card.

Everything else ( goes to 10.x.x.1, my gateway. My guess is that this line is probably absent or messed up on yours.

If you have a relatively simple network configuration, and that line is missing, you can issue this command as root:

 # route add default gw 10.x.x.1

Where 10.x.x.1 is your default gateway.


Alright, given the new information, it looks like your routes are fine. Where is the server that you were pinging located? On the local segment, or remote?

Anyway, lets see where the connection dies:

 traceroute -n

Chances are really good that you'll at least get a response from your gateway, 10.x.x.1. Anything past that means your gateway is routing traffic to you. If you don't get responses, that may indicate a network firewall causing the problem.

Of course, there's still the chance that you're getting traffic, but that your gateway is filtering ICMP packets. It would be diagnostic to try telnetting to google and pretending to be a web browser:

msimmons@newcastle:~$ telnet 80
Connected to
Escape character is '^]'.
GET / HTTP/1.0

HTTP/1.0 200 OK
Date: Mon, 10 Aug 2009 19:20:19 GMT
Expires: -1
Cache-Control: private, max-age=0

You type the "GET / HTTP/1.0" then hit enter twice...though really, if you get the "connected to..." part, you're probably good.

Update once you've tried this!

share|improve this answer
Thanks - see the updates I made to the question. – Brian Aug 10 '09 at 18:51

Two things come to mind right away:

Is DNS working? Can you ping the IP of If is not resolving to an IP, then DNS is not set up correctly.

Run 'cat /etc/resolv.conf' and make sure your DNS server is listed, if it is not configure resolv.conf using these instructions.

Default Gateway:
If DNS is working but you can't ping then you may not have the default gateway set, and can only ping things on your network.

Too add a default gateway, add a line like GATEWAY= to your /etc/sysconfig/network and then restart networking with:

/etc/init.d/networking restart
share|improve this answer
I performed the DNS test ('cat/etc/resolv.conf') and it listed both the primary and secondary DNS servers. I also added the GATEWAY property to the network file along with the GATEWAYDEV (value=eth0) after looking at this page: Even after restarting networking, I am still not able to successfully ping or its IP address. – Brian Aug 10 '09 at 18:36

get DNS fixed (/etc/resolv.conf) to get the NIC to start up every time, edit /etc/sysconfig/network-scripts/ifcfg-eth0 and change the ONBOOT=no line to ONBOOT=yes

share|improve this answer
Already had changed that setting. – Brian Aug 10 '09 at 19:15
So you can't ping, or you simply can't browse, but can ping? – dyasny Aug 10 '09 at 19:18
I can't ping or browse...however, when I ping, it does resolve the host name to it's IP address. – Brian Aug 10 '09 at 19:52
looks like your system is blocked from accessing the outside world. try to run a traceroute to, and see where you are getting blocked – dyasny Aug 11 '09 at 6:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.