Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got single-node Openstack Folsom deployment on a Debian 7.1 server. I've followed the Folsom guide so far and have got everything set up, but when I try to log in through the dashboard, I get the following message:

ConnectionError at /admin/

[Errno 111] Connection refused

Request Method:     GET
Request URL:    https://172.23.18.174/admin/
Django Version:     1.4.5
Exception Type:     ConnectionError
Exception Value:    

[Errno 111] Connection refused

Exception Location:     /usr/lib/python2.7/dist-packages/requests/adapters.py in send, line 243
Python Executable:  /usr/bin/python
Python Version:     2.7.3
Python Path:    

['/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../..',
 '/usr/lib/python2.7',
 '/usr/lib/python2.7/plat-linux2',
 '/usr/lib/python2.7/lib-tk',
 '/usr/lib/python2.7/lib-old',
 '/usr/lib/python2.7/lib-dynload',
 '/usr/local/lib/python2.7/dist-packages',
 '/usr/lib/python2.7/dist-packages',
 '/usr/lib/pymodules/python2.7',
 '/usr/share/openstack-dashboard/',
 '/usr/share/openstack-dashboard/openstack_dashboard']

Server time:    Fri, 12 Jul 2013 16:04:49 +0000

Now I've researched this issue somewhat and have found that connection refused stems from a misconfigured quantum.conf. So I double checked, and my quantum.conf is the following (relevant settings only):

# Address to bind the API server
bind_host = 0.0.0.0

# Port the (sic) bind the API server to
bind_port = 9696

...

# IP address of the RabbitMQ server
rabbit_password = password
# Port where RabbitMQ server is running/listening
rabbit_port = 5672
...
# User ID used for RabbitMQ connections
rabbit_userid = guest

... (everything else is unchanged)

So the login credentials should be OK (nova.conf credentials match too). Other credentials are, of course, sourced upon login.

However, my quantum-server.log shows the following:

2013-07-12 12:00:42 ERROR [quantum.openstack.common.rpc.common] AMQP server on localhost:5672 is unreachable: Socket closed. Trying again in 29 seconds.

Anyone know what exactly is going on here? One thing that I noticed was that I lack a /etc/rabbitmq/rabbitmq.conf file, although I saw it mentioned somewhere. Might this have anything to do with this?

EDIT:

Upon further inspection, it would seem that the services cannot talk to RabbitMQ, as I've found the same error message from quantum logs in the nova-cert.log:

2013-07-12 12:26:47.526 ERROR nova.openstack.common.rpc.common [req-705a947d-28b8-4c1e-8475-2afb19ad96a6 None None] AMQP server on 172.23.18.174:5672 is unreachable: Socket closed. Trying again in 30 seconds.

It should be noted that the machine running all these services is 172.23.18.174. Is it possible that one service is trying for the local IP and the other one for localhost, hence the issue?

EDIT 2:

It seems that all of the nova-* services I have installed so far also far to communicate with Rabbit, as nova-scheduler, nova-consoleauth, nova-cert and nova-conductor all show XXX as their state. However, I have extensively confirmed that credentials are correct, and even tried setting the IPs to either localhost or the local network IP. Either one fails.

share|improve this question
    
have you confirmed that the rabbitmq server is running? you can try logging with iptables or capturing traffic with tcpdump –  dawud Jul 13 '13 at 8:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.