Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows 2012 Domain with a couple of Windows 8 x64 Enterprise members. I want to use Group Policies to map a drive X: to a folder on a file server. The drive X: should be available on the Windows 8 machines for elevated and non-elevated programs. I have configured group policies to create the mapped drive (x:\ mapped to \\filer\stuff\user1\machine1). And - because i know of the elevated/non-elevated problem - group policies set the EnableLinkedConnections key in the registry on the Clients.

So far, so good, i log in with my account on a windows 8 machine (Domain User / Local Admin), open a non-elevated commad prompt, look for X:\ and find it properly mapped to \\filer\stuff\user1\machine1. Next, i open an elevated command prompt, i also have an X:\ there so the "EnableLinkedConnections" setting works but - and that drives me crazy - X:\ is not mapped to the expected location here. In the elevated context, it is mapped to \\filer\stuff. Can anyone explain the reason for that? Both mappings are based on the same configuration in group policies so i really expect them to be the same.

The first idea was that it could be a rights problem but even in the elevated command prompt, i can navigate to the expected target folder without a problem. An idea anyone?

share|improve this question
    
Did you try running any kind of file monitor, e.g. Process Monitor, at the server end to see if the client was trying to access a different (invalid) path on the server during startup? –  sahmeepee Oct 31 '13 at 23:05

1 Answer 1

This is a bug that was fixed in a Windows update released in February 2013.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.