Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a client machine running ubuntu, and I have a windows server 2012 that I connect to using rdesktop.

I need to copy a file from my client machine to the server. I tried sharing a directory like this:

rdesktop -u username -p password -r disk:mydisk=/home/mydir server_IP

I have no idea how to access this shared directory. I have never used rdesktop or windows server before.

please help.

share|improve this question
    
same issue here...\\tsclient is empty. Did you ever find a fix? –  capdragon Sep 18 '13 at 17:05
1  
no. it is still empty for me... –  akonsu Sep 18 '13 at 17:57
    
Please read my answer; it should provide you with the solution. –  Valentin Apr 27 at 14:27

5 Answers 5

It seems that specifications for RDP (MS-RDPEFS) have changed. In specific Windows versions, you also have to forward audio in order to get disk forwarding to work.

share|improve this answer
2  
Thanks, this tip worked for me (rdesktop 1.8.1)! rdesktop -r disk:... -r sound:local:alsa made by share finally show up in Server 2012. –  hmn Feb 12 at 16:42

Open up Explorer. It should show up in Computer with other drives.

share|improve this answer
    
thanks, but I do not see it there. Please refer to my comment under RobW's answer. –  akonsu Jul 13 '13 at 1:33

While in remote session on windows server, it should be listed in Computer among other drives. If it is not, try typing \\tsclient in address bar in Computer. To be specific, your shared directory should be accessible at \\tsclient\mydisk.

share|improve this answer

For this example, I'm naming your host Ubuntu1.

Using this command to access launch rdesktop from Ubuntu1:

rdesktop -u rob -p Password1 -r disk:mydisk=/home/mydir 10.0.0.126

I connect to 10.0.0.126 just fine. I open Windows Explorer and look at the bottom of my list. Just below my Z: drive, I see a drive icon and mydisk on Ubuntu1

I can save files to it, and they appear on Ubuntu1 in directory /home/mydir.

share|improve this answer
1  
in my case it does not show in windows explorer. I can see \\tsclient, but it is empty. The windows server that I am using is AWS EC2 instance, maybe I need to configure something? –  akonsu Jul 13 '13 at 1:32

Try adding -r sound:local to your command.

The final command should look like this:

rdesktop -u username -p password -r disk:mydisk=/home/mydir server_IP -r sound:local

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.