Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed php5 on my newly setup Ubuntu Server 12.04. However, I noticed why does the PHP version is kind of too low? As compared to the official PHP.net website, the recent version is at PHP 5.4.17 or PHP 5.3.27. Is there anything I am missing?

PHP 5.3.10-1ubuntu3.6 with Suhosin-Patch (cli) (built: Mar 11 2013 14:31:48)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
share|improve this question

closed as off-topic by pauska, Falcon Momot, Bryan, Nathan C, jscott Jul 15 '13 at 0:29

  • This question does not appear to be about professional server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

4  
This question appears to be off-topic because it is about a beginners question regarding Ubuntu. Check here: askubuntu.com/questions/109404/… –  pauska Jul 14 '13 at 16:46

2 Answers 2

Ubuntu uses a stable release model, which means that once a release is officially out, changes must remain minimal in order to guarantee consistent user experience. You can find more information about this policy on https://wiki.ubuntu.com/StableReleaseUpdates

This mean that most packages are frozen and will not be updated though the offical repos, which explain why you are not getting the latest php version.

If you need a more recent version, you can either install php from source or upgrade to a more recent version of Ubuntu (13.04 for instance).

share|improve this answer

Use a PPA if you really must have the latest PHP version.

See https://launchpad.net/~ondrej/+archive/php5?field.series_filter=precise

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.