Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to host an old RedHat Enterprise Linux 4 with a 2.6.9 kernel on a Debian 7 core2duo host.

The RHEL4 was originally deployed on a physical server and used only for development on old software, but to prevent hardware fault, we decided to virtualize it with KVM.

We just dd the HDD and it boot just fine. The guest is alone on the host. but now, the newly created guest doesn't work when we try to do 2 jobs at a time:

  1. 1 ssh connection : ok
    2 ssh connections : both shells hang

  2. import data into a database (informix) : takes up to four hours (10 minutes on the original server)

  3. it seems that the problem doesn't appear in the firsts minutes after a reboot.

To benchmark the response of the guest, I've tried this:

pv ibm_data_server_driver_package_linuxia32_v10.1.tar.gz | gunzip | bzip2 > /dev/null

KVM reports that when the guest hangs, CPU is at 25%.

We can't update the guest kernel easily, how do I configure KVM to solve this problem?

My config:

<domain type='kvm'>
<name>generodev</name>
<uuid>90d43c30-ac76-0161-9c89-ea7e1d48dbeb</uuid>
<memory unit='KiB'>524288</memory>
<currentMemory unit='KiB'>524288</currentMemory>
<vcpu placement='static'>2</vcpu>
<os>
  <type arch='i686' machine='pc-1.1'>hvm</type>
  <boot dev='hd'/>
</os>
<features>
  <acpi/>
  <apic/>
  <pae/>
</features>
<cpu mode='custom' match='exact'>
  <model fallback='allow'>core2duo</model>
  <vendor>Intel</vendor>
  <feature policy='require' name='pbe'/>
  <feature policy='require' name='tm2'/>
  <feature policy='require' name='est'/>
  <feature policy='require' name='ss'/>
  <feature policy='require' name='dtes64'/>
  <feature policy='require' name='ht'/>
  <feature policy='require' name='ds'/>
  <feature policy='require' name='lahf_lm'/>
  <feature policy='require' name='tm'/>
  <feature policy='require' name='cx16'/>
  <feature policy='require' name='vmx'/>
  <feature policy='require' name='ds_cpl'/>
  <feature policy='require' name='pdcm'/>
  <feature policy='require' name='xtpr'/>
  <feature policy='require' name='acpi'/>
</cpu>
<clock offset='utc'/>
<on_poweroff>destroy</on_poweroff>
<on_reboot>restart</on_reboot>
<on_crash>restart</on_crash>
<devices>
  <emulator>/usr/bin/kvm</emulator>
  <disk type='block' device='disk'>
<driver name='qemu' type='raw'/>
<source dev='/dev/HOSTED/generodev'/>
<target dev='hda' bus='ide'/>
<address type='drive' controller='0' bus='0' target='0' unit='0'/>
  </disk>
  <controller type='usb' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x2'/>
  </controller>
  <controller type='ide' index='0'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
  </controller>
  <interface type='bridge'>
<mac address='52:54:00:1a:86:85'/>
<source bridge='br0'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
  </interface>
  <serial type='pty'>
<target port='0'/>
  </serial>
  <console type='pty'>
<target type='serial' port='0'/>
  </console>
  <input type='mouse' bus='ps2'/>
  <graphics type='vnc' port='-1' autoport='yes'/>
  <video>
<model type='cirrus' vram='9216' heads='1'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
  </video>
  <memballoon model='virtio'>
<address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
  </memballoon>
</devices>

edit1:

I currently try to check if it don't come from the IO.
after updating my fstab to disable journaling (-o data=ordered) and disabling access time (-o noatime), it dont hang any more...
will test it more tomorrow to be sure, but it seem good right now.

share|improve this question
    
iirc the supported RHEL4 versions were 4.8 and higher, could even be 4.9, so if you're not there, especially on a debian based KVM, well, there's no guarrantee anything will work –  dyasny Jul 15 '13 at 14:25

1 Answer 1

as writen in edit1, my probleme was solved by disabling acces time update and journaling in my ext3 mount.

it seem that the IO access on an old Kernel virtualized by kvm is so slow that it freeze the system if we try multiple read/write.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.