Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a web server I'm trying to make accessible, and although from the command line I get a connection by typing telnet localhost 80, it refuses nonlocal connections. The server is an AWS EC2 node, with a security group of quick-start-1 (22 and 80 are open), and the server has UFW installed, and I have already run ufw allow 80. ps wwaux | grep apache2 shows one root and six www-data processes.

What are the other possibilities for firewalls within the AWS Ubuntu Raring node, or between the node and my notebook? How can I disable the ?ghost firewall?, without compromising my system, so that it is available on port 80?

The system is available on port 22 and it has never given me trouble remotely accessing port 22.

The system is also quite new, and I tried to follow the instructions at https://help.ubuntu.com/community/Drupal.

share|improve this question

1 Answer 1

I would say its a problem with the security group. Make sure apache is installed and traffic from 0.0.0.0/0 is allowed to port 80 on the security group.

You can disable the firewall by doing ufw disable. likewise to enable is ufw enable.

Change security group to allow http(80), https(443), ssh(22), ftp(21) Set up ufw on server to allow http(80), https(443), ssh(22), ftp(21)

Probably also assign an elastic ip to make things easier.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.