Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to move a site from host A to host B and email is hosted in host C and we would like to retain the same. I have set the same MX record for both A and B, however when I run a test at

http://www.dnsstuff.com/tools#dnsReport|type=domain&&value=myclientdomainname.com I get an error

failed message send with: failed cx open with: failed socket connect with: Operation now in progress. Moreover I see that the IP address of the MX records are different when the old host had it (and working fine) and now. The website, however is functioning properly from the new server.

The old host is nexcess and the new host is bluehost, I think mails are in rackspace. Can anyone point me in the right direction?

edit: Just to add more clarity the mx records are mx1.emailsrvr.com and mx2.emailsrvr.com. Thanks

share|improve this question
1  
Is the MX record pointing to an A record if so did you setup the A record? ie mx:mail.mydomain.com a:mail.mydomain.com:10.10.10.10 –  Shutupsquare Jul 16 '13 at 6:31
    
I am sorry, I am not an expert, I have an A record for my primary domain, can you kindly let me know how I can setup an MX record to point to an A record –  skv Jul 16 '13 at 6:40
    
@skv Where are your nameservers records hosted? At domain seller or the website/server host? Are you using any website control panel? –  deppfx Jul 16 '13 at 6:41
    
The nameservers are hosted in domain host, the website works fine after the change, its just the mx records that arent working. –  skv Jul 16 '13 at 6:42
    
Just like how @Shutupsquare pointed, every MX record has to have an A record. So, if your MX record shows up like mail.mydomain.com, then its A record should be resolving to host C Mail server IP address. (mxtoolbox.com/… –  deppfx Jul 16 '13 at 6:45
show 4 more comments

1 Answer 1

up vote 0 down vote accepted

One of your nameservers is broken: ns1.rhostbh.com is intermittently timing out. This doesn't generally impact users, as the other nameserver will be tried, but a DNS checker will flag it as an error.

share|improve this answer
    
Thank you for this information, I have also tested now and yes what you pointed is a fact, however I have set it up in a reseller panel myself, and can you suggest any resolution to the issue –  skv Jul 16 '13 at 7:13
    
Turns out that the issue was only with the report thanks –  skv Jul 16 '13 at 8:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.