Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set up DNS scavenging on our Windows Server 08 R2 boxes as we had records in there that were duplicated and some dating back to 2004!

I set the no-refresh and refresh-after intervals both to 3 days, zone scavenging is enabled on each zone and at a server level the Ageing settings are enabled for scavenging too.

However, when we run the scavenge nothing happens (even after a few days) so we checked the settings again and found a box that said "this zone can be scavenged after" and the date was 11/01/2014...

Is there a way to change this value so it is for example, today - waiting until 2014 for a simple DNS scavenge is a bit much...

Cheers, Myles

P.S: I followed the "holy grail" guide to Windows DNS Scavenging for all the processes: http://blogs.technet.com/b/networking/archive/2008/03/19/don-t-be-afraid-of-dns-scavenging-just-be-patient.aspx

share|improve this question
1  
Myles, did you reload the zone after setting scavenging up? –  TheCleaner Jul 16 '13 at 15:51
    
Doh! That was it! Add as an answer and I'll accept it. Cheers dude :) –  Myles Gray Jul 17 '13 at 6:55
add comment

1 Answer

up vote 2 down vote accepted

After setting up scavenging on a DNS zone in Windows, you need to reload the zone in order for the proper "this zone can be scavenged after" date to be calculated and set.

Reloading the zone should fix your issue.

share|improve this answer
1  
After the next reload, the timestamp should update itself to the current time + the current refresh interval –  Mathias R. Jessen Jul 17 '13 at 13:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.