Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set WSGISocketPrefix /var/run/wsgi in apache.conf

And in my virtual host config

WSGIDaemonProcess myuser user=myuser group=myuser threads=25 python-path=VIRTUAL_ENV_PATH 
WSGIProcessGroup myuser
WSGIScriptAlias / /var/www/myuser/httpdoc/wsgi.py

But still it gives this error:

Permission denied: mod_wsgi (pid=8942): Unable to connect to WSGI daemon process 'myuser' on '/var/run/wsgi.8936.0.1.sock' after multiple attempts.

What could be another reason for this error?

share|improve this question
    
Please add the following info to your question: operating system, version, any Linux Security Modules in place (if any, AppArmor, SELinux, ...). With this little info, there is little to do to help you. –  dawud Jul 16 '13 at 18:26
    
It's CentOS 6.4 and SELinux is disabled. –  brsbilgic Jul 16 '13 at 18:32
    
What Apache MPM are you using and what version of mod_wsgi? You can get this with some versions of mod_wsgi, even if paths for socket set right, if using perchild or peruser MPMs. –  Graham Dumpleton Jul 16 '13 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.