Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I know this may sound incredibly stupid and there is probably an easy solution but I can't seem to find it. Friends of mine recently upgraded their server for their small business from the POS old one. New hardware and a change from Windows Server 2003 to Windows Server 2012. I've got everything they need transfered over and running except for printing. They need to be able to print to printers in the vans their technicians use from the server via remote desktop. In other words the use a laptop to remote desktop into the server and need to print invoices out from the remote server to printers attached locally via usb.

On the old server they just installed the identical driver and that was it, they could print as needed. On this server no matter what we seem to do we can't get it to print remotely, and in the process we also discovered that the server can't even print to the network printer. It sees the printer on it's network and it sees (through redirect) the printers in the vans but when you hit print it claims it did and nothing happens.

There isn't an issue with the printers themselves as every other device we have can print to them without issues.

Is there some setting that is inhibiting the server from printing? Is there something I need to install (print server?) to add the functionality?

Thanks in advance for helping me out here

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I have seen problems like this when moving from win2003 server to win2008 and 2012.

The problem is the print driver, and the new "easy print" system in windows. Some print drivers do not work with easy print.

I should mention that the best solution is to use a "generic" print driver (under mfger "Microsoft") if that can be made to work with your printer.

This kb has the known story (discusses win2008, but also applies to win2012):

http://www.shiprush.com/knowledge_bases/shiprush/srxa-0464.txt


Problem: Nothing prints when using Remote Desktop & local Zebra printer

Scenario:

If ShipRush is running on Windows 2008 or Windows 7, and both:

1) Is accessed via remote desktop and 2) The Zebra printer is attached locally

labels do not print.

Discussion:

This is a known problem with the Microsoft "Easy Print" system. Easy Print is used automatically to handle printing when the host system is Windows 7 or Windows 2008.

Solution:

Use the Group Policy Editor to disable Easy Print:

1) Log out of the remote desktop session

2) On the host. As administrator run gpedit.msc

3) Navigate to: Computer Configuration | Administrative templates | Windows Components | Remote Desktop Services | Remote Desktop Session Host | Printer Redirection

4) Locate the setting: "Use Remote Desktop Easy Print printer driver first"

5) Typically, this setting is "Not Configured"

6) Change this setting to: "Disabled"

Test:

Start a new remote desktop session. Printing to the Zebra printer should now work.



share|improve this answer
    
Thanks again for taking time to help me. I tried these steps to no avail. I went ahead and tried the exact same steps I used on the server on a different computer and the printing works fine. The printing on the server is still broken, but there was an improvement. When I hit print the notification for low toner appeared on the screen (which has never happened before) but it still did not print. I'm wondering if there's some setting I am unaware of that prevents print requests from going through, or if the drivers are somehow only half working. Any thoughts? –  Chris Jul 17 '13 at 15:21
    
I can't print to the local network printer, but the printing via remote desktop in the vans is working now! Thanks so much, that was the critical thing. This other issue is a convenience issue but isn't inhibiting work from getting done. If you have any suggestions off the top of your head they are appreciated, but I don't want to bother you too much as you've been a huge help already –  Chris Jul 17 '13 at 15:42

protected by Michael Hampton Nov 10 '13 at 1:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.