Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've a Windows Server 2008 R2 with 8 public IPs assigned (fixed), recently i've installed VirtualBox and create a VirtualMachine with OpenBSD.

I would like to give one IP to the VM, but every try that i tested this fails.

In Windows there's a public IP 200.100.100.208 (for this example), that IP i've configured in OpenBSD VM at the /etc/hostname.em0 file, which content is:

inet xxx.xxx.xxx.208 255.255.255.255

/etc/mygate file is:

zzz.zzz.zzz.65          Same gateway ip than windows

i put the same mask that is assigned in windows for each IPs.

At windows i've created rules for firewall to VirtualBox.exe application.

In VirtualBox VM's setting: Network the current configuration:

Attached to: Bridged Adapter
Name: Intel(R) 82574L Gigabit Networkd Connection
Advanced:
    Promiscuous Mode: Deny
    Cable connected is checked.

i can't figure out what is missing... if is needed some information, ask please, i'll give such information.

thanks!!

New information:

i've removed IP from windows config

Windows Config:

IPv4 Address:     xxx.xxx.xxx.209
IPv4 Subnet Mask: 255.255.255.255

IPv4 Address:     xxx.xxx.xxx.210
IPv4 Subnet Mask: 255.255.255.255

IPv4 Address:     xxx.xxx.xxx.211
IPv4 Subnet Mask: 255.255.255.255

IPv4 Address:     xxx.xxx.xxx.212
IPv4 Subnet Mask: 255.255.255.255

IPv4 Address:     xxx.xxx.xxx.213
IPv4 Subnet Mask: 255.255.255.255

IPv4 Address:     xxx.xxx.xxx.214
IPv4 Subnet Mask: 255.255.255.255

IPv4 Address:     xxx.xxx.xxx.215
IPv4 Subnet Mask: 255.255.255.255

IPv4 Address:     yyy.yyy.yyy.83
IPv4 Subnet Mask: 255.255.255.224

IPv4 Default Gateway  zzz.zzz.zzz.65

IPv4 DNS Servers   hhh.hhh.hhh.202
                   hhh.hhh.hhh.200

The IP xxx.xxx.xxx.208 i've removed from windows.

If i set the ip xxx.xxx.xxx.208 in windows, when i start openbsd, an error message apear: duplicate IP address xxx.xxx.xxx.208

share|improve this question
1  
If you configure the IP on the BSD VM, you'll have to remove it from the Windows PC. Since the network adapter in the VM is bridged, it's treated just like another device on the network. –  Jim G. Jul 16 '13 at 23:28
    
yeah, I forgot to say that, but still does not work. –  Gabriel Jul 16 '13 at 23:35
    
Can you ping any of the Windows IPs from BSD or vice versa? –  Jim G. Jul 16 '13 at 23:43
    
no... pinging using hostname or ip address doesn't work –  Gabriel Jul 16 '13 at 23:45
2  
That doesn't sound right. What's the subnet mask of the gateway? –  Jim G. Jul 16 '13 at 23:57
show 2 more comments

1 Answer 1

up vote 2 down vote accepted

Based on the info above, it appears that your subnet mask is incorrect. Based off of 8 usable IPs, your subnet mask should probably be 255.255.255.240. Try that. You'll want to change it on the Windows host as well.

share|improve this answer
    
I concur, the netmask 255.255.255.255 is probably wrong, with that mask, the host will only be able to communicate with itself. Use the same netmask that you're using for an already-working IP on the windows server. –  Hugo Jul 18 '13 at 0:14
    
The problem was the netmask, I took one of the server's secondary IPs (one in the same subnet as the VM: xxx.xxx.xxx.209) and changed the netmask to 255.255.255.248, then on VM put that IP as gateway. I also had to enable the "Rounting and Remote Access" service on the windows server. –  Gabriel Jul 18 '13 at 1:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.