Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a website in Azure, configured as a standard website. The website is configured to use TFS2012 in the cloud for Continuous Deployment. Originally, I have been using the HostedController and everything works perfectly. As soon as I check in a changeset, TFS triggers a BuildEvent. The BuildEvent compiles the code and places it in the Drop folder as expected. It is then deployed to the Azure Website successfully.

I have been using the AzureContinuousDeployment Build Template. The only change I have made is installing TFS2012 on an on premise server. I have successfully configured it to use the Collection from TFS2012 in the cloud also set up the build agent.

Now when I change the same Build Definition to use my on premise BuildController rather than the HostedController, everything seems to work until it tries to move the files to the drop location I get an exception. The files are actually all moved to the Drop location whether it be the local share or out in TFS in the cloud. The only thing that does not happen is the zip for the package isn't created.

Exception Message: The deployment package file (*.zip) was not found. Ensure that PackageAsSingleFile msbuild property is not set to False. (type FileNotFoundException)
Exception Stack Trace:    at System.Activities.Statements.Throw.Execute(CodeActivityContext context)
   at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
   at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

I changed the Drop location to be on an internal server rather than trying to drop it into the cloud to rule out firewall issues, but I still get the same error.

I have also included the argument for MSBuild /p:PackageAsSingleFile=true

This has no effect on the process, I still get the same error message. I assume I have a configuration issue somewhere, just not sure. Any ideas?

share|improve this question
up vote 0 down vote accepted

Installed Visual Studio on the build server an it solved my problem. I was under the impression that Team Viewer was all that was required.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.