Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In order to learn a bit about system administration, I've installed a Centos vm using Vmware on my local machine running Windows 7. Everything seems to be working fine since I can access the internet from the Centos machine, but I am unable to ping the host machine from the vm or vice versa. I get the message "destination host unreachable". I also have a win7 vm and I run into the same problem when attempting to ping between it and the host. There's a third computer on the network which is able to ping both of the vms and the host machine. The vms are also able to ping this other computer. The only problem I have with pinging seems to happen between the host and the vms. When I switch the vm network adapter over to NAT, the problem goes away and I'm able to ping successfully.

As I understand it, this should be working since the bridged vm is supposed to act like another physical device on the network.

share|improve this question
    
maybe firewall on win 7 is blocking icmp packets. Also try to stop firewall on the linux - "service iptables stop" –  ALex_hha Jul 18 '13 at 8:42
    
I tried disabling all the firewalls. I'm pretty sure that's not the problem though, since the pinging works between all computers except between the host and the vms. –  mowwwalker Jul 18 '13 at 8:52
add comment

1 Answer

AHA! After over 10 hours of trying to figure this out, I finally got it.

All I had to do was disable the "DNE LightWeight Filter" by right-clicking my network adapter and going to properties. This is apparently a driver by the company Citrix, which must have been installed for the SonicWall vpn I use.

share|improve this answer
    
If you ever come back to this place: accept your own answer to mark it solved. –  JohannesM Mar 8 at 2:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.