Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

SLES ~12 server, with Apache 2, named based virtual hosting enabled and working, but need port based as well...

I have added to listen.conf

listen 8008

I then defined a virtual host statement:

<VirtualHost *:8008>
  Documentroot /srv/www/foo
  <Directory /srv/www/foo>
    ... etc

Then gone into yast > security > firewall > allowed services > advanced and added TCP port 8008.

When I visit the page I get an error 101, connection to X was interrupted.

nmap from another server shows:

PORT     STATE    SERVICE
8008/tcp filtered unknown

netstat:

User       Inode      PID/Program name
tcp        0      0 0.0.0.0:8008            0.0.0.0:*               LISTEN
0          11230896   17302/httpd2-prefor

iptables:

limit: avg 3/min burst 5 tcp dpt:8008 flags:0x17/0x02 LOG flags 6 level 4 prefix `SFW2-INext-ACC-TCP '
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:8008

What's going wrong? Many thanks in advance!

share|improve this question
    
You make sure the port is open in the firewall? –  Satanicpuppy Jul 18 '13 at 12:36
    
yes, I thought I did that via yast as mentioned above ? –  user127379 Jul 18 '13 at 12:46
    
you can temporarily disable firewall to figure out the root of the issue –  ALex_hha Jul 18 '13 at 13:34
    
Ah, I'm blocked by another external firewall that's why! Doh! –  user127379 Jul 18 '13 at 14:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.