Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm a programmer working over a VPN.

I use local databases most of the time, but my local SQL Server 2005 has "Link Server" server object pointing at the production server.

This has been working great (albeit, slow over VPN) until the company had some IT people install a new firewall.

Now, my linked servers on my local database don't work when I try to access data through them (Example: a simple select command)

Named Pipes Provider: Could not open a connection to SQL Server [53].

Furthermore,

I am able to connect to the databases just fine through SSMS or through SQLCMD on the command line.

I'm very confused as to why I am able to connect to the remote server by 2 methods, but not via linked server.

Any tips?

Thanks!

share|improve this question
    
What was the VPN issue, just out of curiosity? –  squillman Aug 10 '09 at 22:33

1 Answer 1

up vote 2 down vote accepted

It could be because your linked server is using the named pipes protocol to connect and the new firewall is not permitting that through. You can do one of 2 things:

  1. Ask the firewall admin(s) to allow incoming traffic on TCP Port 445 (the named pipes port)
  2. Change your linked server's provider to use TCP/IP instead of Named Pipes.

For #2, if you're using the SQL Native Client (SQLNCLI) you change the provider via SQL Server Configuration Manager on your workstation. Open that up, expand SQL Native Client Configuration and click on Client Protocols. Either move TCP/IP to a higher order than Named Pipes or, if it is already higher, disable Named Pipes.

The firewall folk might balk at your request to open port 445, so you may be stuck changing the protocol of your linked server provider.

share|improve this answer
    
Squillman, thanks for the great response. –  George W Bush Aug 10 '09 at 22:06
    
It turned out to be a VPN issue... and my brain isn't working quite right :) –  George W Bush Aug 10 '09 at 22:06
    
I am having the same issue; did you ever get around the VPN issue? –  AbeP Feb 27 at 9:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.