Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On a 2003 windows server I have a com+ application which is available to its clients on everybody, anonymous permissions. Windows XP machnes doesn't have problems with accessing, activating, lanuching com+ object, however windows 7 client has some troubles.

When Win7 user tries to connect to to com+, it gets an error that the remote object doesn't implement IDispatch interface. I reckon it is security issue.

When i set the same user on the client and remote machine problem is solved but it is not a solution, Win 7 should get access to com+ being in everybody/anonymous group.

Is there a difference in sending credentials in xp/win7? What can I set on win7 machine to solve the issue?

share|improve this question
1  
Have you tried running the application as an administrator? (right click -> "Run as Administrator") –  Romdeau Jul 24 '13 at 6:34

2 Answers 2

It might be either a local administrator / UAC issue or possibly an authentication protocol problem. By default Windows 7 doesn't support NTLM v1 or LM authentication. Several of the COM+ services I've seen didn't support NTLM v2 or Kerberos, only the older methods.

share|improve this answer

I have solved the problem. Probably the answer was that on the client machine, additional library wasn't installed which included interface used in communication.

Without it com+ client probably wanted to fetch interface definition from a remote server, with no luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.