Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Setting up Windows Server 2012 Datacenter as a VPN (with everything as default settings), I receive no errors upon installation, then I restart. Upon trying to connect to the VPN, here is what happens:

Using internal IP from a Windows 8 computer
If I set Type of VPN to "Automatic" and try to connect, I get:

Error 919: The connection could not be established because the authentication protocol used by the RAS/VPN server to verify your username and password could not be matched with settings in your connection profile.

If I set Type of VPN to "L2TP/IPSec" and try to connect, I get:

Error 810: A network connection between your computer and the VPN server was started, but the VPN connection was not completed. This is typically caused by the use of an incorrect or expired certificate for authentication between the client and the server. Please contact your Administrator to ensure that the certificate being used for authentication is valid.

Using external IP from a Windows 8 computer
If I set Type of VPN to "Automatic" and try to connect, I get:

Error 800: The remote connection was not made because the attempted VPN tunnels failed. The VPN server might be unreachable. If this connection is attempting to use an L2TP/IPSec tunnel, the security parameters required for IPSec negotiation might not be configured properly.

If I set Type of VPN to "L2TP/IPSec" and try to connect, I get:

Error 789: The L2TP connection attempt failed because the security layer encountered a processing error during initial negotiations with the remote computer.

Are these all supposed to related? If they are, what needs to be done to fix the problem?

share|improve this question

3 Answers 3

When that happened to me, I simply installed a SSL certificate for the SSL connection.

It seemed to have fixed it.

share|improve this answer

Error 919: The connection could not be established because the authentication protocol used by the RAS/VPN server to verify your username and password could not be matched with settings in your connection profile

The above error tells you exactly what the problem is, but you then state that you tried this to fix it.

If I set Type of VPN to "L2TP/IPSec" and try to connect

The type of tunnel (L2TP, PPTP, etc) is not the same as the authentication method.

Authentication methods include kerberos, MSCHAP, MSCHAP v2, etc, and that's where you should be looking.

Compare the client settings to the server settings, and you should be good.

share|improve this answer
up vote 0 down vote accepted

Apparently this was a problem with DHCP and nothing else. Here is what I did to fix this problem:

  1. Open Routing and Remote Access
  2. Right click on server name
  3. Properties
  4. IPv4 tab
  5. Changed From DHCP to Static address pool
  6. From (Start) "192.168.1.200" to (End) "192.168.1.255"
  7. Apply
  8. OK
  9. Try to connect to VPN from internal and external computer and it worked!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.