Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed OpenVPN on my arm-based sheevaplug (OS is Debian 7 Wheezy, kernel 3.8.8.) but as soon as i try to start the service i receive the following error:

[....] Starting virtual private network daemon: serverSIOCSIFADDR: No such device
: ERROR while getting interface flags: No such device
SIOCSIFDSTADDR: No such device
: ERROR while getting interface flags: No such device
SIOCSIFMTU: No such device
 failed!

Also modeprobe tun outputs the following:

libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file '/lib/modules/3.8.8/modules.dep.bin'

Any suggestions on how to resolve this? I would appreciate any help. Thanks.

share|improve this question
    
And what do you have for your OpenVPN config? –  Zoredache Jul 24 '13 at 21:35
    
I found the solution. I recently upgraded my kernel to 3.8.8 but i didn't upgrade the modules so it was using ver. 2.6.30.2. I downloaded the modules for this kernel and i unzipped the folder under /lib/modules/3.8.8. It works... Thanks anyway! –  Evan Sap Jul 24 '13 at 21:43
    
self-answer your question, and mark your answer as accepted. –  Zoredache Jul 24 '13 at 21:46
    
I have low reputation points so i can only answer my question after 7 hours from the initial question. I will do this asap. –  Evan Sap Jul 24 '13 at 21:55
add comment

1 Answer

I found the solution. I recently upgraded my kernel to 3.8.8 but i didn't upgrade the modules so it was using ver. 2.6.30.2. I downloaded the modules for this kernel and i unzipped the folder under /lib/modules/3.8.8. It works... Thanks anyway!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.