Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've switched host for a couple of websites. I switched the nameservers about 24 hours ago and within about 6 hours was able to see that the new location was showing up fine on my mobile phone browser, but the browsers on my computer still showed the old host's version.

Googled a bit and found out about clearing the dns cache with ipconfig/flushdns on the command line. No joy. I'm on windows 7 so I tried again opening the command line running by right click and 'run as administrator' and tried again. No joy.

Checked the windows32/drivers/etc/hosts file and the domains aren't listed in there.

Is there anything else I can try? I'm on a three mobile dongle in the UK on my main computer (where all my files to fix the new version which everyone else can see are). Could it be Three need to update something? Last time I did this it only took a couple of hours and that was from the same old host to the same new host and was only two days ago!

help!

share|improve this question
    
Be a little more clear, what do you mean by "I switched" and "new location". What is the exact problem? –  Mathias R. Jessen Jul 25 '13 at 11:37
1  
You're using the wrong tools for this job. dig and nslookup are the right tools. Anything else is like trying to hammer in a screw with an air conditioner. –  Ladadadada Jul 25 '13 at 11:37
    
Basically I have a domain registered with 1&1 and hosted with my old hosting company. I want to move to a new hosts so I've switched the dns settings with 1&1 to point the domain to my new hosting company. I did this over 24hours ago. Within 6 hours I was able to view the version of the site in on the new host on my smartphone using 3G. But still, over a day later, on my main computer, via it's completely separate internet connection, when I check I get the oldversion which is still sitting on the old hosts servers –  Zaphod Beeblebrox Jul 25 '13 at 11:43
    
@ladadadada (cool name by the way) don't suppose you'd care to elaborate, all the info I've found online tells me to use ipconfig. Is this something I can do on a windows 7 machine? Is it my local settings which are the problem? Or is it something to do with my internet provider? –  Zaphod Beeblebrox Jul 25 '13 at 11:45
2  
@Ladadadada, I agree on dig. Using nslookup is like trying to hammer in a screw with a broken air conditioner. –  Jenny D Jul 25 '13 at 11:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.