Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed Windows 7 RTM on my developer machine. Right after the installation I added my domain account to local administrators group and added the machine to company's domain.

We use local folder mapped as a network drive to store dll's that we reference. The drive is created by:

subst S: "D:\DllFolder"

The drive mapped ok, however the following issue occured: When I tried to open a solution using Visual Studio 2008 it told me that I needed to run it as administrator to be able to use the asp.net projects hosted on IIS. I run VS as administrator and the solution opened fine but that VS instance could not see the S: drive.

Can anyone tell me how can I work around that problem? (The temporary solution that works is to disable the UAC, but that is not acceptable in the long run.)

Appreciate any suggestions.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Subst is user specific, you need to run subst as administrator as well.

share|improve this answer

Well, .NET is very sensitive to permissions while running on a non-local drive. It can detect that even "through" the subst. You might be better served by mapping the drive directly:

net use s: \\server\path\to\DllFolder

But I doubt that will help.

You would be better served by doing the development locally (on your local drive) and synchronizing your work to the central location. Either using a source-control program (like Subversion), or just copying.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.