Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Yesterday, I was given two 160GB hard drives that used to form a striped RAID in an Apple xserve. The xserve is completely non-functional, but the issue is unrelated to the hard drives and I don't think either drive is corrupted. There are no plans to purchase another xserve or other apple server equipment.

So, how can I get the data off? So far, I used a SATA to USB tool combined with Mac Disk Utility to make an image of each drive. The images will verify and attach, but won't mount. The attached images show that disk utility found a striped raid and shows the two raid slices including that the other raid slice is missing. But if I attach both, a third disk magically attaches in Disk Utility with the name of the raid showing. But I cannot find anyway to mount this third disk either.

So I can get the data from these drives? Preferably in a way that uses the disk images I created so I don't mess up anything on the real drives.

Any solutions or ideas are greatly appreciated. Many thanks in advance!

share|improve this question
    
You can probably reassemble the data... The Xserve was running Mac OS X, right? –  ewwhite Jul 26 '13 at 3:21
    
Yes, it was running mac os x server 10.6. How can I reassemble the data? Thanks! –  Jared Jul 26 '13 at 3:26
add comment

1 Answer

up vote 3 down vote accepted

If you have the disk images (or want to use the actual disks), try using Prosoft Data Rescue to piece things together. They have a guide that outlines the process.

I hate the fact that these are striped disks, but since you get a third disk that appears, see if you can modify it in Disk Utility, or even with a third-party tool like Disk Warrior or the Data Rescue mentioned above.

If all else fails, any reputable data recovery firm will have the requisite tools to help recover the data.

share|improve this answer
    
Thanks for your help. For future readers, I used Data rescue as suggested. A quick scan recovered a bunch of files, and a deep scan recovered many more. Unfortunately, even with a deep scan not all the files were recovered. I gave disk warrior a try too (actually I had done this before posting here), but bailed after around 6 hours stuck on Step 5: Locating directories. Though there are so success stories on the internet of DiskWarrior recoveries lasting several days. I guess if they want every last file, we'll have to use a data recover firm. Thanks again. –  Jared Jul 29 '13 at 8:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.