Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Recently, I've started to receive this error my logs:

drivers/hid/usbhid/hid-core.c: can't reset device, 0000:00:1a.0-1.2/input1, status -110

This error happens about 2-6 times per minute, and every time it appears my SSH session will freeze entirely for 1-3 seconds.

I wasn't sure what the Status -110 was, so I looked up where the errors are defined in the linux kernel, and 110 is a ECONNREFUSED (Connection timed out error).

Upon further investigation, I believe it to be caused by the Supermicro iKVM device. If I perform a iKVM reset operation in the IPMI control panel, the usb devices are reset and the error disappears until my IPMI session times-out, then it occurs again. My guess is that the IPMI "suspends" the virtual usb devices when the session is closed and this is causing the USBHID module in the kernel to freak out because it can't reset them (?).

I haven't tried a server reboot quite yet and I am running firmware rev 1.60 on my IPMI while the latest is 1.86. I plan to update and reboot this weekend if all else fails. I have also tried disabling power-save for USB devices without luck.

Kernel Information:

Linux pve 2.6.32-20-pve #1 SMP Wed May 15 08:23:27 CEST 2013 x86_64 GNU/Linux

Thanks in advance.

share|improve this question
1  
I have no real answer but can confirm the issue. I'm not using KVM/IPMI at all so disabled all redirections in the BIOS, including 'SOL' (without knowing what it is). Then the 'can't reset device' issue poped up. As soon as I enable SOL console redirection, the issue goes away... My theory is that using SOL redirection prevents the system of putting the USB into suspend... but that's an uneducated guess only. –  Stephan Jan 21 at 10:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.