Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've created an Amazon EC2 AMI from an existing server, ie I'm not using one of amazon's AMIs. I can launch it and I can see on the console output that it's started up, however I can't SSH to it, either as root or as a local user that was on the original server we copied.

I've tried with a few different keys, including some that i had made already. When I try to connect, it offers the SSH key but it doesn't except that and will ask me for a password. I tried the (root) password for that server. "PermitRootLogin yes" is in the /etc/ssh/sshd_config

I know I'm connecting to the SSH server, since it gives me the RSA fingerprint the first time. I've tried running this on US and EU.

Any ideas?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This is my fault. I forgot to add 'root' to the AllowGroups in sshd config.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.