Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Today I want to upgrade a server, but it lag on java 8 upgrade, I use Ctrl + C and stop upgrade, now when I want to upgrade, I have this problem: Can anybody help me?

 root@mg1:/home/system# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
18 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Setting up oracle-java8-installer (8b97-0~webupd8~0) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing oracle-java8-installer (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up php5-common (5.4.4-14+deb7u3) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing php5-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of php5-fpm:
 php5-fpm depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-fpm (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-cli:
 php5-cli depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-cli (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-curl:
 php5-curl depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-curl depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-curl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-gd:
 php5-gd depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-gd depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-gd (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-imap:
 php5-imap depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-imap depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-imap (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-intl:
 php5-intl depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-intl depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-intl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mcrypt:
 php5-mcrypt depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-mcrypt depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-mcrypt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-mysql:
 php5-mysql depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-mysql depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-mysql (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-pspell:
 php5-pspell depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-pspell depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-pspell (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-recode:
 php5-recode depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-recode depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-recode (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-snmp:
 php5-snmp depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-snmp depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-snmp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-sqlite:
 php5-sqlite depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-sqlite depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-sqlite (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-tidy:
 php5-tidy depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-tidy depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-tidy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-xmlrpc:
 php5-xmlrpc depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-xmlrpc depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-xmlrpc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php5-xsl:
 php5-xsl depends on phpapi-20100525; however:
  Package phpapi-20100525 is not installed.
  Package php5-cli which provides phpapi-20100525 is not configured yet.
  Package php5-fpm which provides phpapi-20100525 is not configured yet.
 php5-xsl depends on php5-common (= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.

dpkg: error processing php5-xsl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of php-pear:
 php-pear depends on php5-common (>= 5.4.4-14+deb7u3); however:
  Package php5-common is not configured yet.
 php-pear depends on php5-cli; however:
  Package php5-cli is not configured yet.

dpkg: error processing php-pear (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 oracle-java8-installer
 php5-common
 php5-fpm
 php5-cli
 php5-curl
 php5-gd
 php5-imap
 php5-intl
 php5-mcrypt
 php5-mysql
 php5-pspell
 php5-recode
 php5-snmp
 php5-sqlite
 php5-tidy
 php5-xmlrpc
 php5-xsl
 php-pear
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
2  
Possible duplicate of serverfault.com/questions/175278/… –  Rik Schneider Jul 26 '13 at 23:30
    
No, it doesn't work –  Ternatish Jul 27 '13 at 0:06
1  
Have you tried turning it off and on again? –  Michael Hampton Jul 27 '13 at 0:59
    
Did you try apt-get -f install –  F. Hauri Jul 27 '13 at 5:18
    
And where exactly is Java 8 in the wheezy repos? The problem here is clear: config: /var/cache/debconf/config.dat is locked by another process. –  dawud Jul 27 '13 at 5:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.