Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

For some reason I can't get grub to load the new kernel.

I tried removing the old kernels with aptitude and running update-grub but it still loads the old kernel - even though I've removed it!

I then manually updated the grub config file (/boot/grub/menu.lst) and restarted but still no joy.

Commands run to try to get grub to update:

$ sudo aptitude remove linux-image-3.2.0-23-virtual
$ sudo aptitude remove linux-image-3.2.0-24-virtual # ..etc up to 3.2.0-49

$ sudo update-grub

$ sed -i 's/3.2.0-23/3.2.0-49/ig' /boot/grub/menu.lst

$ sudo reboot

Current state of system:

$ grub --version
grub (GNU GRUB 0.97)

$ uname -r
3.2.0-23-virtual

$ cat /boot/grub/menu.lst | grep 3.2.0-49
title vmlinuz-3.2.0-49-virtual
kernel /boot/vmlinuz-3.2.0-49-virtual root=LABEL=root ro
initrd /boot/initrd.img-3.2.0-49-virtual

$ cat /boot/grub/menu.lst | grep 3.2.0-23
# <nothing>

$ ls -l /boot
-rw-r--r-- 1 root root  795318 Jun 18 18:39 abi-3.2.0-49-virtual
-rw-r--r-- 1 root root  140637 Jun 18 18:39 config-3.2.0-49-virtual
drwxr-xr-x 2 root root    4096 Jul 27 10:03 grub
-rw-r--r-- 1 root root 5788488 Jul 26 17:49 initrd.img-3.2.0-49-virtual
-rw------- 1 root root 2892052 Jun 18 18:39 System.map-3.2.0-49-virtual
-rw------- 1 root root 4964112 Jun 18 18:39 vmlinuz-3.2.0-49-virtual

This was the first time I was prompted to update the kernel by apt via email. So it looks like the previous unattended upgrades that installed kernels failed to update grub either.

I'd prefer not to risk updating to grub 2 as this is a VPS and I won't have supergrubdisk to save me if something goes haywire.

share|improve this question
    
Which virtualization technology is this? –  Michael Hampton Jul 28 '13 at 10:52
    
It's KVM virtualization being used. –  techjacker Jul 28 '13 at 13:13
    
Hmm. And who is your provider? –  Michael Hampton Jul 28 '13 at 13:17
    
It's digital ocean. You were right that was the problem. The only way to upgrade is through their control panel I just discovered. Thanks a lot for putting me on to the solution. –  techjacker Jul 28 '13 at 13:20
    
Yep, it's one of Digital Ocean's biggest mistakes. And why I don't use them anymore. Feel free to post it as your own answer. –  Michael Hampton Jul 28 '13 at 13:30
show 1 more comment

1 Answer

up vote 1 down vote accepted

The problem turned out to be my hosting provider, Digital Ocean.

The only solution for Digital Ocean customers is to upgrade via the panel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.