Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got a SQL Server 2008 Standard Edition installed on a Server 2008 R2, OS and SQL Server got newest Service Packs and updates installed.

The SQL Server is up and running but I cant connect to the SSRS via Webinterface, every time i will get this message:

(provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.

In the Event Log, I got a lot of Schannel Errors, ID 36882 and 36888. (Remote Servers Certificate is not trustworthy) The Certificate is pinned to the Event, its a Self Signed Fallback Certificate.

Things I tried to do to solve the problem:

  • Double check all Settings in the SSRS Configuration Utility.
  • Change the "SecureConnectionLevel" value in rsreportserver.config to 0.
  • In the SSCM Configuration Manager, turn off forced encryption for SQL Server Network Configuration and SQL Native Client.
  • In the cliconfig.exe, turn off forced encryption for Named Pipes and TCP/IP.

SSRS still tries to check the trust status of the self signed fallback cert.

I just want to get Access to the SSRS to install MS CRM 2011 to the DB, it doesnt matter if this will be achieved by turning off SSL cause all connections are trusted and in the local network or even fixing the certification error.

share|improve this question
up vote 0 down vote accepted

I could resolve the issue by installing IIS on the Server and create a self signed certificate.

After assigning the cerfiticate to the Connections in the SSRS Configuration Utility I could not just browse the SSL Version of the Page but also the HTTP Version at port 80. (Still without SSL but error wont show up once SSL is configured)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.