Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up a Postfix server on my Ubuntu VPS and it works for sending email from the mail utility in the command line. I set up SPF records, DKIM, pretty much everything I could read about. However, I'd like to be able to send and receive email without SSHing into my box each time.

When I try to set up my server (borogov.es) with my mail client, and I use "mail.borogov.es" as my outgoing mail server, I get "Server not responding." I feel like this is an access issue of some sort, but I'm not sure.

I'm not running a firewall. What could be going on?

share|improve this question

2 Answers 2

See what netstat -tlnp returns; if Postfix is listening to 127.0.0.1:25, then it's bound to loopback interface instead of a network card interface.

In that case your Postfix /etc/postfix/main.cf does not have inet_interfaces = all line.

The other option is that your ISP does not allow private SMTP servers.

share|improve this answer
    
It is listening on all, and DigitalOcean does allow SMTP servers. –  tekknolagi Jul 30 '13 at 12:44

You should not be attempting to send mail from your email client on port 25; rather using 587 (the standard submission port). Port 25 is meant for transfer between mail servers, and many home ISPs block it to reduce spam from compromised home computers.

Your Postfix server isn't listening on port 587:

$ telnet mail.borogov.es 587
Trying 198.199.97.52...
telnet: connect to address 198.199.97.52: Connection refused

This means you probably forgot to set up a submission section in Postfix's master.cf configuration file. It should look something like:

submission inet n       -       n       -       -       smtpd
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
share|improve this answer
    
I just paste that into my master.cf? –  tekknolagi Jul 30 '13 at 18:35
    
So I get this: i.imgur.com/suBgWrt.png –  tekknolagi Jul 30 '13 at 18:38
    
After restarting Postfix, that is. –  tekknolagi Jul 30 '13 at 18:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.