Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have samba 4.0.6 as AD DC and fileserver on ubuntu 12.04 in a Mac environment. After some time the OS X clients will not connect to the server with the error message: "The file server will not allow any aditional users to log on. Try to connect again later. Restarting samba service fixes the problem temporarely.

The server is used in a little company with only 5 users all using OS X and at the time connecting using smb.

I've added "max connections = 20000" in smb.conf (as shown in end of this post), but it didn't have any effect.

# testparm smb.conf
Load smb config files from smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Unknown parameter encountered: "server role"
Ignoring unknown parameter "server role"
Unknown parameter encountered: "dns forwarder"
Ignoring unknown parameter "dns forwarder"
Processing section "[Arkiv]"
Processing section "[Internt]"
Processing section "[Kunder]"
Processing section "[Programvare]"
Processing section "[Ressurser]"
Loaded services file OK.
Press enter to see a dump of your service definitions

    workgroup = KONVOI
    realm = KONVOI.LAN
    template shell = /bin/bash
    winbind enum users = Yes
    winbind enum groups = Yes
    winbind use default domain = Yes
    idmap_ldb:use rfc2307 = Yes
    idmap config * : backend = tdb

    comment = Aktive prosjekter
    path = /mnt/data/Kunder
    read only = No
    max connections = 20000
share|improve this question
Why do you use Samba if there are no windows machines in your environment? There are better solutions for centralized identity management and file sharing specific to the *NIX world, like LDAP, Kerberos, NFS. – dawud Aug 15 '13 at 8:14
can also look at netatalk and just run AFP. – Doon Nov 20 '14 at 20:47

This looks like it might be a bug. It's probably a bug in samba that causes it to think it's out of connections when it's not, or a bug in OS X that causes it to not close connections to samba cleanly.

However, you may gain some benefit from explicitly specifying the deadtime global option (the number of minutes until a connection with no open handles is closed, in minutes); the default is to keep those forever for some reason.

That said, when you're dealing with a lightly supported compatibility interface (OS X AD and SMB/CIFS support) interfacing to reverse-engineered replacement for the thing it was designed to interface to, you're asking for trouble. Especially if you have only a few users, and nobody is using windows, don't use samba. If everyone is using a mac, the most reliable and painless thing to do will be to use OS X server (and I'd warrant you wouldn't need too much of a mac to service the needs of 5 people).

If you can't do that, or don't want to, OS X can also work with NFS and LDAP as Dawud suggests. In either case, all of these suggestions would be better architecture and much less error-prone.

share|improve this answer
up vote 0 down vote accepted

This problem got solved. Unfortunately I didn't remembered to update this post. I think upgrade of Samba was the solution.

Regarding "why samba4" as some have mention in this tread:

I'm it professional in a company serving smb customers. Some has just Mac some have both windows and mac. My experience today is that samba 4.1 is reliable and flexible as you can use it as domain controller for both Mac and PC (and get all of the AD features for managing PC clients). Today samba 4.1 has superseded samba 3. To install samba 4.1 just for smb and use another ldap server isn't a rational choice. And if the customers some day get some PCs I will be happy I have samba AD and not another ldap server.

I think. I will not sell OS X servers for other than small customers as Apple no more sell real servers (I don't regard Mac mini as a "real" server).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.