Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem using munin (on Ubuntu 10.05 LTS). No graphs are available. Instead, an image placeholder is shown. I tried different settings, but it does not work. I used http://munin-monitoring.org/wiki/CgiHowto2 to set up CGI. I also tried to find my error using http://munin-monitoring.org/wiki/FAQ_no_graphs.

But still, no graph is available. My settings and logs and telnet test: https://gist.github.com/Bjoernsen/bd7b9ab506ac55748292

Tell me, if I did not share all information

share|improve this question

2 Answers 2

Try to open "CGI image" directly and check the source. It must be an error messages from CGI.

share|improve this answer
    
I do not find an error message. If I call http://localhost:5000/munin-cgi/munin-cgi-graph/server/cooler.server/cpu-day.pn‌​g, I get a html (index) page with status 200, "Opened log file" (munin-cgi-html.log), 127.0.1.1:80 xxxx - - [30/Jul/2013:12:52:54 +0200] "GET /munin-cgi/munin-cgi-graph/server/cooler.server/cpu-day.png HTTP/1.1" 200 1228 "localhost:5000/munin/server/cooler.server/cpu.html" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.72 Safari/537.36" (apache2/access.log). –  Bjoernsen Jul 30 '13 at 11:00
    
What did you see when open /munin-cgi/munin-cgi-graph/server/cooler.server/cpu-day.png? Also check that munin generates RRD. Did they exists in data folder? –  Paul Rudnitskiy Jul 30 '13 at 12:12
    
When I open the url, I see something like the index (html) page without any CSS. I know, it should be a .png. In the folder /var/lib/munin/server/ are many .rrd files. But they are from this morning (5h old). I think they should be from now +- 5min. Maybe I had a working version during my tests :-) –  Bjoernsen Jul 30 '13 at 12:39

I found the reason, why no change in /etc/apache2/sites-available/munin effected the server. There was a file link from '/etc/apache2/conf.d/' to the apache2.conf file in the munin folder. This file was always used and not my setting file.

Now, my settings are more or less the same like the settings found at http://munin-monitoring.org/wiki/CgiHowto2

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.