Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use Webmin to administrate my Ubuntu 12.04 x86_64 machine. Yesterday, as often, I got notified of updates and installed them. During the installation process, libapache2-mod-php5 has been uninstalled, and since then I can't restart Apache.

When I try to reinstall it I get the following error:

The following packages have unmet dependencies: libapache2-mod-php5 : Depends: apache2-api-20120211 but it is not installable PreDepends: apache2 (>= 2.4)

If I understood well it means I need Apache 2.4 minimum, right?

If so, as I use Virtualmin which seems not proven compatible with Apache 2.4, how can I roll back my changes?

Below are parts of the dpkg.log file:

2013-07-30 14:40:30 upgrade bind9 1:9.8.1.dfsg.P1-4ubuntu0.6 1:9.8.1.dfsg.P1-4ubuntu0.7
2013-07-30 14:41:47 upgrade mysql-server 5.5.31-0ubuntu0.12.04.2 5.5.32-0ubuntu0.12.04.1
2013-07-30 14:41:59 upgrade mysql-common 5.5.31-0ubuntu0.12.04.2 5.5.32-0ubuntu0.12.04.1
2013-07-30 14:42:00 upgrade mysql-client 5.5.31-0ubuntu0.12.04.2 5.5.32-0ubuntu0.12.04.1
2013-07-30 14:42:01 upgrade mysql-client-5.5 5.5.31-0ubuntu0.12.04.2 5.5.32-0ubuntu0.12.04.1
2013-07-30 14:42:25 upgrade mysql-server-core-5.5 5.5.31-0ubuntu0.12.04.2 5.5.32-0ubuntu0.12.04.1
2013-07-30 14:45:20 upgrade icedtea-6-jre-cacao 6b27-1.12.5-0ubuntu0.12.04.1 6b27-1.12.6-1ubuntu0.12.04.2
2013-07-30 14:45:23 upgrade openjdk-6-jre-lib 6b27-1.12.5-0ubuntu0.12.04.1 6b27-1.12.6-1ubuntu0.12.04.2
2013-07-30 14:45:27 upgrade icedtea-6-jre-jamvm 6b27-1.12.5-0ubuntu0.12.04.1 6b27-1.12.6-1ubuntu0.12.04.2
2013-07-30 14:45:34 upgrade openjdk-6-jre-headless 6b27-1.12.5-0ubuntu0.12.04.1 6b27-1.12.6-1ubuntu0.12.04.2
2013-07-30 14:45:53 upgrade liblcms2-2 2.2+git20110628-2ubuntu3 2.2+git20110628-2ubuntu3.1
2013-07-30 14:46:09 upgrade libmysqlclient-dev 5.5.31-0ubuntu0.12.04.1 5.5.32-0ubuntu0.12.04.1
2013-07-30 14:46:14 upgrade libmysqlclient18 5.5.31-0ubuntu0.12.04.1 5.5.32-0ubuntu0.12.04.1
2013-07-30 14:46:35 upgrade linux-firmware 1.79.4 1.79.6
2013-07-30 14:47:00 upgrade linux-libc-dev 3.2.0-48.74 3.2.0-51.77
2013-07-30 14:47:10 upgrade openjdk-6-jre 6b27-1.12.5-0ubuntu0.12.04.1 6b27-1.12.6-1ubuntu0.12.04.2
2013-07-30 17:18:55 upgrade libedit2 2.11-20080614-5~precise+1 2.11-20080614-6~precise+1
2013-07-30 17:19:09 install libjson-c2 <none> 0.11-2~precise+1
2013-07-30 17:19:09 upgrade libjson0 0.9-1ubuntu1 0.11-2~precise+1
2013-07-30 17:19:32 upgrade php-apc 3.1.13-1~precise+1 4.0.1-4~precise+1
2013-07-30 17:19:33 install php5-apcu <none> 4.0.1-4~precise+1
2013-07-30 17:19:36 upgrade php5-mysql 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:19:38 upgrade php5-imap 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:19:40 upgrade php5-ldap 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:19:43 remove php5-geoip 1.0.8+repack.1-1~precise+1 <none>
2013-07-30 17:19:45 upgrade php5-mcrypt 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:19:46 upgrade php5-curl 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:19:48 upgrade php5-sqlite 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:19:49 install libvpx1 <none> 1.0.0-1
2013-07-30 17:19:53 upgrade php5-gd 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:19:55 upgrade php5-imagick 3.1.0~rc2-1~precise+1 3.1.0~rc2-1~precise+2
2013-07-30 17:19:57 upgrade php5-cli 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:20:00 upgrade php5-common 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:20:10 upgrade php5-cgi 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:20:23 configure php5-cgi 5.5.1+dfsg-1~precise+1 <none>
2013-07-30 17:20:23 status unpacked php5-cgi 5.5.1+dfsg-1~precise+1
2013-07-30 17:20:23 status unpacked php5-cgi 5.5.1+dfsg-1~precise+1
2013-07-30 17:20:23 status half-configured php5-cgi 5.5.1+dfsg-1~precise+1
2013-07-30 17:20:27 status installed php5-cgi 5.5.1+dfsg-1~precise+1
2013-07-30 17:20:28 startup packages remove
2013-07-30 17:20:28 status installed libapache2-mod-php5 5.4.17-1~precise+1
2013-07-30 17:20:28 remove libapache2-mod-php5 5.4.17-1~precise+1 <none>
2013-07-30 17:20:29 install php5-json <none> 1.3.1+dfsg-1~precise+1
2013-07-30 17:20:57 upgrade php-pear 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:21:10 upgrade php5 5.4.17-1~precise+1 5.5.1+dfsg-1~precise+1
2013-07-30 17:21:25 install libunistring0 <none> 0.9.3-5
2013-07-30 17:21:27 install libgettextpo0 <none> 0.18.1.1-5ubuntu3
2013-07-30 17:21:28 install libstdc++6-4.6-dev <none> 4.6.3-1ubuntu5
2013-07-30 17:21:29 install g++-4.6 <none> 4.6.3-1ubuntu5
2013-07-30 17:21:31 install g++ <none> 4:4.6.3-1ubuntu5
2013-07-30 17:21:32 install libdpkg-perl <none> 1.16.1.2ubuntu7.1
2013-07-30 17:21:36 install dpkg-dev <none> 1.16.1.2ubuntu7.1
2013-07-30 17:21:39 install build-essential <none> 11.5ubuntu2.1
2013-07-30 17:21:42 install html2text <none> 1.3.2a-15
2013-07-30 17:21:43 install gettext <none> 0.18.1.1-5ubuntu3
2013-07-30 17:21:45 install intltool-debian <none> 0.35.0+20060710.1
2013-07-30 17:21:47 install po-debconf <none> 1.0.16+nmu2ubuntu1
share|improve this question
    
I have the same problem.I've installed apache 2.4 but it doesn't help (maybe because I compiled it myself) –  kraabus Jul 31 '13 at 15:52

3 Answers 3

umm you change your repos ?

Try apt-get -f install

Try it from ssh and before:

apt-get clean all

apt-get update

apt-get -f install

Or try manually

apt-get install libapache2-mod-php5

share|improve this answer
    
I did change them to have php 5.4. Thanks but same... –  Nabab Jul 31 '13 at 15:56
    
Umm cant help you more, but if you cant solve that contact me and I check your server :) (@gmail.com like my nickname.) –  Skamasle Jul 31 '13 at 19:22

I am in pretty much the same boat. apt-get install libapache2-mod-php5 results in

The following packages have unmet dependencies. libapache2-mod-php5 : Depends: apache2-api-20120211 but it is not installable PreDepends: apache2 (>= 2.4) E: Unable to correct problems, you have held broken packages.

share|improve this answer
    
I upgraded Apache through a repo: apt-add-repository ppa:ptn107/apache but now it's mod_fcgid that has dependencies problem (it needs apache2.2-common) –  Nabab Jul 31 '13 at 15:57
up vote 0 down vote accepted

I was using the repository ppa:ondrej/php5 in order to have php 5.4 running on 12.04LTS.

It happens they upgraded PHP from 5.4.x to 5.5.x, which seems to need Apache 2.4, while I had 2.2. I tried upgrading Apache through another repository, and then it was some features needed by Virtualmin which was incompatible with Apache 2.4.

So I uninstalled PHP and Apache, then removed the 2 repositories, and added ppa:ondrej/php5-oldstable, which is version 5.4 and will remain so. See https://launchpad.net/~ondrej/+archive/php5

Works fine now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.