Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

At work, we are currently using a Linksys WRT54GL (yeah, i know), running DDWRT v.23. There is about 50 computers plugged into our network, all routed through a Linksys SRW2048 switch.

The problem is that all connections are very slow, even the routers GUI is very slow.

I've checked the load values and they seem to be fine. Although the memory free is only about .6 MB.

Is there any settings I should do or something other I need to think of?

EDIT:

Sorry, the memory usage is very high. It's only about 0.6 MB left. What can I do to free some memory? Things like wireless networking is disabled.

Thanks!

share|improve this question
1  
I had this exact switch and the web interface was always horribly slow... –  Antoine Benkemoun Aug 11 '09 at 14:51
1  
To be fair you're using a consumer router to handle non-consumer load - this might/should work I'd consider getting something designed for the load. –  Chopper3 Aug 11 '09 at 14:51
    
Chopper3, yeah i'm aware of that. Unfortunately this is my only option. –  alexn Aug 11 '09 at 14:53

8 Answers 8

I have quite a similar setup WRT54GS with 60/70 computers and DDWRT 0.24SP1.

Try looking for connection timeout, if set to 3600 set it down to 300, look for max active connections as well and set it to a reasonable value like 1024/2048 for your network size. I'm rarely having more than 1000 active connections at a time with timeout set to 300.

[EDIT] For the memory issue it might be related to the maximum active connection setting. Do not set it to 4096 as it consumes quite a bit of memory. Set it to 1024.

share|improve this answer
    
This is often the most likely cause on these low memory routers. Connection tracking with long timeouts uses a fair amount of memory. Especially if the workstations are doing anything untoward. –  Dan Carley Sep 29 '09 at 19:25

This could be any number of things. Break down the issue into smaller parts and start isolating the issue.

  • Disconnect all machines except a test one and the router. still slow?
    • If yes, connect a second test machine and test between.
    • If still yes, you may have a bad switch.
  • If no, connect the other machines one at a time (or in small groups) and see if you can narrow things down to a specific machine.
  • try using Wireshark.
    • Look for ARP flooding
    • abnormally large number of connections
    • unusually chatty machines
  • Have your virus checked your machines?
  • look for spayware
share|improve this answer
3  
Oh god, I thought spyware was bad, now there's spayware? What's next? Eunuchs? –  Ernie Aug 11 '09 at 16:16
1  
"Beware the spayware, my son! The jaws that bite, the claws that catch! Beware the Jubjub bird, and shun The frumious Bandersnatch!" –  Peter Aug 11 '09 at 19:42

I'm not familiar with the DDWRT Can you open a shell on it and run top? You've turned it into a Linux box, why not debug it like one?

share|improve this answer
    
Because that goes beyond my knowledge. I'm only able to do some very basic debugging as my knowledge about DD-WRT in special and linux in general is limited. –  alexn Aug 11 '09 at 15:08

Have you tried disabling the web and telnet configuration interfaces and only using ssh, by turning off the webserver on the router you might be able to reduce load. At my current job we have a similar setup for wireless users (ddwrt is only on ap, but not net gw). I haven't tried turning off the web UI but it might help out.

share|improve this answer

I think the only thing you can do is try first unplugging most of the machines and see how it handles routing traffic for a few systems at first, then scale it up gradually to see where your load is peaking.

I first suspect that you're overloading the unit. 50 machines is a lot for a consumer based piece of hardware to handle, and you don't know if systems on your network aren't streaming data or possibly are infected with something that is flooding the routing table on the router.

First try doing the unplug then replugging of systems to see if there's a "tipping point". Second, I'd put in a system somewhere with two NIC's...running Linux...and route traffic through it transparently as a proxy. Maybe you can see if that will give you some insight on traffic load as well...unusual traffic may be a sign of malware activity that is also killing your connection.

You might be able to use that system as a web proxy (squid is your friend) to help alleviate some of the load on your poor little router...

share|improve this answer

honestly, if you're running 50 Windows machines on one flat network, then it's likely that 20-30% of the traffic on the wire is broadcast traffic. I can't readily find port/buffer stats on that switch, but I'm guessing that you're sharing buffer space across at least 8 ports, and with that much broadcast traffic, they're all going to be getting hammered.

It kinda looks like that switch is capable of Layer3...if that's the case, I'd highly suggest separating out your systems into VLANs to decrease the size of your broadcast domain.

share|improve this answer

Capture data and analyse the trace file while network slow,maybe full occupied bandwidth is bottleneck.

share|improve this answer

Those SRW2048 switches tend to have failed capacitors. Ours kept dropping from Gb to 100Mb on the majority of ports because of it (odd, I know). Try a better switch if you can get a loaner for testing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.