Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Installed Ubuntu Server 13.04 64 bit on an Intel S1200BTL board. The official Intel cd came with a few Linux drivers, but the one for onboard video is missing. I am certain there is no hardware acceleration because Unity is slightly choppy and /usr/lib/nux/unity_support_test -p yields "no" under "Not software rendered" (why the confusing double negation?)

First, I looked through the 5 pages of available software for the S1200BT family in the Intel website. Closest match was a driver for S1200BTS which I was tempted to try but froze in my tracks when I read "Please DO NOT use this package on IntelĀ® Server Board S1200BTL" in the description. Fair enough, though I can't help but wonder what's the deal with S1200BTL in particular.

Then I tried the web-based Intel driver update utility. I let it run for about 3 hours and it seemed quite determined to keep rendering that progress bar until the end of time.

Next stop was the Intel Linux Graphics Installer utility. After a few installation hurdles, I ran it and was told there was nothing to do because I had no Intel graphics card. What the...?

So then I ran lspci | grep VGA and lo and behold, turns out my card was actually...

Matrox Electronics Systems Ltd. MGA G200e [Pilot] ServerEngines (SEP1) [rev07]

At this point, I went to the Matrox website and rummaged around the legacy drivers (looks like MGA G200e is no longer supported) circa 2005-2007. Problem is, those drivers, including some unofficial ones I found by some tuxx guy, are made for version 7.1 of the X server at most, and Ubuntu 13.04 uses 1.13 version. I read about some guys who managed to downgrade X to 7.1 to get the drivers working, but it looked SO PAINFUL.

Anyone ran into this sort of issue and found an easier solution?

share|improve this question
    
If this is a server, why do you need a GUI on it? If it's required, just use XFCE or something that doesn't need 3D and can work with the default X drivers. –  Sven Jul 31 '13 at 19:39
    
We're actually setting these up for a third party to run their software on. They requested a GUI to make their lives easier, I guess. Working locally, you almost not notice the lack of hw accel. BUT when you log in remotely using Team Viewer, it craaaaaaawls to the point of becoming unusable. As a temporary solution, just like you suggested, we installed a lighter DE (LXDE). Now we can work remotely using Team Viewer; it's usable, but still quite slow. It would be really nice to get hw accel... –  dario_ramos Jul 31 '13 at 19:50
    
I am not sure HW accel will help you to speed up TeamViewer if it's fast enough locally. The problem is that all this transparency and 3D stuff is difficult to put through any Remote Desktop solution and you should prefer the most visually boring GUI you can find, with solid colors, no transparency, composing and whatnot. –  Sven Jul 31 '13 at 20:01
    
Agreed, we're in the process of tweaking LXDE and Team Viewer to use as little resources as possible. Anyway, it really came as a surprise that Intel had no support for a scenario like mine, since they have been pretty intense on the open source trenches lately. So I thought something had slipped me by. –  dario_ramos Jul 31 '13 at 20:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.