Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running CentOS 6.4. After installation, I had two logical volumes, /dev/VolGroup/lv_home and /dev/VolGroup/lv_root. I then deleted the lv_home and added the free space to lv_root.

So now if I run lvdisplay I get:

 --- Logical volume ---
  LV Path                /dev/VolGroup/lv_root
  LV Name                lv_root
  VG Name                VolGroup
  LV UUID                fAme1e-o5CI-y4kT-j6jr-m99X-lciI-bh28KI
  LV Write Access        read/write
  LV Creation host, time localhost.localdomain, 2013-07-31 17:07:44 +0200
  LV Status              available
  # open                 1
  LV Size                464,76 GiB
  Current LE             118978
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:0

But the space is somehow not available. When I run df -h I get:

/dev/mapper/VolGroup-lv_root
                       50G   47G   17M 100% /
tmpfs                 3,9G     0  3,9G   0% /dev/shm
/dev/sda1             485M   64M  396M  14% /boot

What am I supposed to do to actually have the 460G space?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You expanded the logical volume, but the underlying file system still thinks it only has the old disk available.

The next (and the last) step is to resize the volume; for example with ext* filesystems you do resize2fs /dev/mapper/VolGroup-lv_root. That should do it, and nowadays online with the mounted filesystem, too. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.