Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok, so I have a server at work that I am setting up sites on. It has a Wordpress site in the root, a phpBB forum in a child directory, and a support site in another directory. I'm able to access both the phpBB and support site, but can't access wordpress.

Server: Ubuntu 11.04 with LAMP. Mod rewrite enabled. Structure: /var/www/ ; /var/www/onlyus/ ; /var/www/support/

Perms: Files at 644, directories at 755. Select cache, upload, etc directories at 777 .htaccess:

<Directory "/var/www"> ///woops, little error there (didn't fix it though)
  Options +Indexes FollowSymLinks +ExecCGI
  AllowOverride AuthConfig FileInfo
  Order allow,deny
  Allow from all  

<IfModule mod_rewrite.c>
  RewriteEngine On
  RewriteBase /
  RewriteRule ^index\.php$ - [L]
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteRule . /index.php [L]

I just can't figure out why the wordpress site won't load but the 2 child sites will. Any advice or possible causes of this?

EDIT: apache2.conf

share|improve this question
Can you clarify your directory structure? You have /var/www in your post and /home/domain/www in your configuration. Can you also post your VirtualHost and Apache configurations? Did the WordPress site ever work? Sounds trivial, but in the name of triage, have you tried loading the site from multiple PCs and clearing your browser cach(es)? – Craig Watson Aug 1 '13 at 18:27

This may be a cache problem, if you've tried accessing the domain root before, your browser may have cached the response as a file download (unlikely but possible) - so it's always best to clear caches before you troubleshoot, as well as closing/reopening browsers for good measure.

Can you try downloading the file and taking a look at its contents? If the file contains PHP code, then the PHP interpreter isn't parsing the file, which would certainly be strange given that your other applications running PHP seem to work.

If the downloaded file contains HTML only, I would hazard a guess that the problem is a caching problem and not necessarily tied to the server - in this case, try a few different browsers/PCs.

share|improve this answer

on debian based machines u need to make sure you have is installed


and the following files are linked to there counter parts in /etc/apache2/mods-available

/etc/apache2/mods-enabled/php5.load /etc/apache2/mods-enabled/php5.conf

share|improve this answer

Add Handler to your apache config

  AddHandler application/x-httpd-php .php 
share|improve this answer
PHP would need to be installed for phpBB and the support site (which I assume is running PHP) to display. – Craig Watson Aug 1 '13 at 18:25
Yeah, I'm not quite THAT new... – mikedugan Aug 1 '13 at 18:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.