Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem when I want to connect to Cassandra remotely I run it on ubuntu server and can connect to it through cassandra-cli

connect localhost/9160

But when I connect remotely I have an error

Connection Refused

Can some one help me what the problem? Is it for firewall or something else?

Thanks

share|improve this question

closed as off-topic by Ward, Falcon Momot, mdpc, Jenny D, Nathan C Aug 5 '13 at 17:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – Falcon Momot, mdpc, Jenny D, Nathan C
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Find out what interface is the cassandra process using:

# netstat -an | grep 9160.*LISTEN

If it only listens in the localhost interface, you need to reconfigure cassandra to allow remote connections.

Also, check if your firewall allows remote connections to that port:

# iptables -nvL

And add a rule if it doesn't.

share|improve this answer
    
Thanks I will try it –  S.Mohamed Mahdi Ahmadian zadeh Aug 3 '13 at 10:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.