Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server (linux base) in which i installed dotcms and it runs on port 80 and openssl is on port 443. both are started in running process. Recently i installed apache on my server. and when i started apache it stuck because default ssl port on apache is 443 and apache is 80, both of them are already running. Just for my task i started only apache without ssl on port 90. but i want to start ssl with apache as well obviously on different port. Is is possible to bind apache ssl with same openssl?

I need my default dotcms in running process i can't stop it in any case, i can only restart my dotcms service if apache start required. but i need dotcms and apache to run both parallel.

see image on that link (because of less reputation i could not upload image) http://developers89.byethost14.com/images/ssl.png

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Yes, it is possible to bind Apache to different port and still use SSL.

Replace the Listen directives in your apache config. The config should contain line like

Listen 80
Listen 443

Apache will listen on the ports defined with these configuration options. Replace them, and Apache will listen on a different port.

However, you still need to tell Apache what to serve on the ports above. Suppose you want Apache to start listening on port 8080 (plain), and 4433 (ssl). Then you need to replace the Listen directives to

Listen 8080
Listen 4433

After this, define two VirtualHosts on these ports like this:

NameVirtualHost 0.0.0.0:8080
NameVirtualHost 0.0.0.0:4433

<VirtualHost 0.0.0.0:8080>
    ServerName *
    DocumentRoot /var/www/plain
</VirtualHost>

<VirtualHost 0.0.0.0:4433>
    ServerName *
    DocumentRoot /var/www/ssl

    SSLEngine On
    SSLCertificateFile /the/certificate/file
    SSLCertificateKeyFile /the/key/file
</VirtualHost>

If you restart Apache, it will listen on 8080 for unencrypted connections, and on port 4433 for SSL. Be sure not to have any old VirtualHost definition which contain the wrong port number.

share|improve this answer
    
Thanks, port is on but when i try mydomain.com:4433 it gives error "SSL connection error" Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have. –  Waqas Ahmed Aug 2 '13 at 11:02
    
when i try to enable ssl module by this command on linux a2enmod ssl. it gives error : * Restarting web server apache2 ... waiting (98)Address already in use: make_sock: could not bind to address [::]:4433 and when i disable that module and restart apache 4433 port is running and facing error highlighted in above comment –  Waqas Ahmed Aug 2 '13 at 11:09
    
Stop the apache webserver, and make sure no Apache instances remain running. Check if the ports are open with the "netstat -napt|grep 4433" command (there should be no output). Then run a2enmod to enable the SSL module. Also, make sure that the "Listen" directives appear in the config files only once (e.g. the second "Listen 4433" directive will result an error). –  Lacek Aug 4 '13 at 10:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.