Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Despite installing and enabling the 10G fiber card, data copy or transfer is still happening on a 1G rate.

share|improve this question

closed as unclear what you're asking by Ward, Falcon Momot, Magellan, mdpc, Ladadadada Aug 5 '13 at 9:50

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You seem to have forgotten to add units to your bandwidth rates. There's quite a difference between GB and Gb. In fact, 1GB/s is about the expected transfer rate for a 10Gb card. –  Ladadadada Aug 5 '13 at 9:50
add comment

1 Answer

I'm not surprised.

  1. Increasing the MTU has to happen on all network devices in the segment, all switches, all NICs, etc.
  2. Many file copy mechanisms are single-threaded, and as you don't say which one you're using, but I bet it's rsync or NFS, the performance is severely limited by the capability of a single thread to hammer away at 10Gbit.
  3. Are you sure your values are in Gigabits/second, not Gigabytes/second, as there's a factor of 8 difference there.. Could be the cause of some confusion.
  4. There's a huge load of options for configuring a 10Gbit NIC's drivers, TCP timestamping, offload, synchronous ACK, all of which can limit the performance of a 10Gbit NIC.

I know this is for Linux, and you're on SunOS, but have a read of this: http://landley.net/kdocs/ols/2009/ols2009-pages-169-184.pdf

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.