Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to setup puppet's dashboard to be monitor the status of my servers. With the below shown configurations, my clients (or nodes) only show up as Unreported and says Has not reported in the dashboard overview - however the node can communicate with the server and pull changes as it's supposed to, but nothing appears. I have followed these docs trying to set it up, but I have no idea of what I am doing wrong.

What could be a possible issue?

// Server /etc/puppet/puppet.conf
[master]
reports = store,http
reporturl = http://192.168.1.101:3000/reports/upload

// Client /etc/puppet/puppet.conf
[agent]
report = true
share|improve this question
    
Can you confirm what documentation you used? There aren't any links in your question. –  Craig Watson Aug 3 '13 at 5:56
    
Also add what versions of Puppet and Puppet dashboard you are using. –  Ladadadada Aug 3 '13 at 7:51
    
Are your delayed job workers running? –  Shane Madden Aug 3 '13 at 19:18

1 Answer 1

The reports are sent to the dashboard by the puppet master, not by the agent.

Make sure the Master can access 192.168.1.101:3000 (is there a firewall)?

Make sure you haven't overridden anything important (such as the report option) at environment level in your puppet.conf

Make sure the Dashboard upload web service is running on port 3000.

Check the puppet server auth.conf to make sure you have

path /report
auth yes
method save
allow *

If you have added authentication to your dashboard HTTP server on port 3000, then the report upload will fail (as you cannot configure authentication for the report uploads). In this case, you need to change the reporturl to (EG) port 3001, then add a separate HTTP virtualhost for this port that is restricted to just the puppetmaster(s).

puppet.conf example:

reporturl = http://puprepprd01.its.auckland.ac.nz:3001/reports/upload

Apache example:

Listen 3001
<VirtualHost *:3001>
    ServerName puprepprd01.its.auckland.ac.nz
    DocumentRoot /usr/share/puppet-dashboard/public/
    <Directory /usr/share/puppet-dashboard/public/>
        Options None
        AllowOverride AuthConfig
        Order allow,deny
        allow from pupappprd01.its.auckland.ac.nz
        allow from pupappprd02.its.auckland.ac.nz
        allow from pupappdev01.its.auckland.ac.nz
        deny from all
    </Directory>
    LogLevel warn
    ErrorLog /var/log/httpd/dashboard_error.log
    CustomLog /var/log/httpd/dashboard_access.log combined
    ServerSignature On
</VirtualHost>

If still having issues, check the logs on your puppetmaster and dashboard servers; both the puppet logs and the http logs. Are connections coming in and being rejected?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.