Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to remove the Remote Desktop Session Host on a new VM that was installed as part of a test script to take a vanilla VM to a Terminal Server. However, upon uninstalling the above I wasn't unable to RDP onto the server, so I had to install it back again. How can I remove it and then fix RDP?

This is a Role which isn't installed by default, but when you uninstall it does it effect default configurations that are in place before you install it?

share|improve this question
    
Check that Remote Desktop connections are enabled on the Remote tab of the System Properties. –  joeqwerty Aug 4 '13 at 15:56
    
Had done that, and deactivated and reactivated it also. –  PnP Aug 4 '13 at 15:56
    
Check to see if the Windows Firewall has the appropriate rule enabled. There should be a rule named "Remote Desktop (TCP-in)" that needs to be enabled for the appropriate network profile. –  joeqwerty Aug 4 '13 at 16:00
    
This was all configured as it should be, very strange ! –  PnP Aug 4 '13 at 17:29

1 Answer 1

Any specific errors on connection attempt on a client side after role removal? (you either may try to look through server logs; even without RDP you should be able to view server logs remotely)

It could easily be something to do with RDS licensing. As you removed RDS role, it left you with only 2 simultaneous RDP connections to the server allowed - so it's make sense to verify whether you have some RDS seesions not properly logged off & preventing you from opening new RDS connection.

You may also try & use mstsc /admin to connect via RDP after role removal (see details on this option in following article Use command line parameters with Remote Desktop Connection)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.