Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When trying to cluster two MariaDB Galera servers on RHEL 6 together using the command:

mysqld -uroot --wsrep_cluster_address=gcomm://

and the screen then sits there, and looks at me with this output:

130805 10:26:50 InnoDB: The InnoDB memory heap is disabled
130805 10:26:50 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130805 10:26:50 InnoDB: Compressed tables use zlib 1.2.3
130805 10:26:50 InnoDB: Using Linux native AIO
130805 10:26:50 InnoDB: Initializing buffer pool, size = 128.0M
130805 10:26:50 InnoDB: Completed initialization of buffer pool
130805 10:26:50 InnoDB: highest supported file format is Barracuda.
130805 10:26:50  InnoDB: Waiting for the background threads to start
130805 10:26:51 Percona XtraDB (http://www.percona.com) 1.1.8-29.3 started; log sequence number 5715012
130805 10:26:51 [Note] Plugin 'FEEDBACK' is disabled.
130805 10:26:51 [Note] Event Scheduler: Loaded 0 events
130805 10:26:51 [Note] WSREP: Read nil XID from storage engines, skipping position init
130805 10:26:51 [Note] WSREP: wsrep_load(): loading provider library 'none'
130805 10:26:51 [Note] mysqld: ready for connections.
Version: '5.5.29-MariaDB'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MariaDB Server, wsrep_23.7.3.rXXXX

As far as I can tell, it seems to be working. I then issued the command to connect to this cluster master:

$ mysqld -uroot --wsrep_cluster_address=gcom://mariadbclstr02.local.net

130805 11:27:21 InnoDB: The InnoDB memory heap is disabled
130805 11:27:21 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130805 11:27:21 InnoDB: Compressed tables use zlib 1.2.3
130805 11:27:21 InnoDB: Using Linux native AIO
130805 11:27:21 InnoDB: Initializing buffer pool, size = 128.0M
130805 11:27:21 InnoDB: Completed initialization of buffer pool
130805 11:27:21 InnoDB: highest supported file format is Barracuda.
130805 11:27:21  InnoDB: Waiting for the background threads to start
130805 11:27:22 Percona XtraDB (http://www.percona.com) 1.1.8-29.3 started; log sequence number 1598129
130805 11:27:22 [Note] Plugin 'FEEDBACK' is disabled.
130805 11:27:22 [Note] Event Scheduler: Loaded 0 events
130805 11:27:22 [Note] WSREP: Read nil XID from storage engines, skipping position init
130805 11:27:22 [Note] WSREP: wsrep_load(): loading provider library 'none'
130805 11:27:22 [Note] mysqld: ready for connections.
Version: '5.5.29-MariaDB'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MariaDB Server, wsrep_23.7.3.rXXXX

Now they're both just sitting there, and nothing is happening as far as I can tell. Is there a way to see if they are doing this correctly? I'm following the documentation at the MariaDB website: https://kb.askmonty.org/en/getting-started-with-mariadb-galera-cluster/. I can also use netcat to connect to both servers using nc -vz mariadbclstr02.local.net 3306 and also nc -vz mariadbclstr01.local.net 3306

share|improve this question

1 Answer 1

up vote 0 down vote accepted

From what I discovered, instead of issuing the commands like I did, I had to edit the /etc/my.cnf and add those lines. Instead thought, I created a /etc/my.cnf.d/zabbix_cluster.cnf file and put the lines specified at https://kb.askmonty.org/en/getting-started-with-mariadb-galera-cluster/. Then I was able to start MySQL properly. Then after editing the /etc/my.cnf/zabbix_cluster.cnf config file, I had to start the cluster up by issuing /etc/init.d/mysql start --wsrep_cluster_address=gcomm:// which would then initialize a new cluster and allow others to join.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.