Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

.. it looks like at least two of packages that comes from EPEL is broken:

[alexus@wcmisdlin02 ~]$ sudo yum update --skip-broken
Loaded plugins: refresh-packagekit, security
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libmodplug.x86_64 0:0.8.7-1.el6.rf will be updated
--> Processing Dependency: libmodplug.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64
---> Package libmodplug.x86_64 1:0.8.8.3-2.el6 will be an update
---> Package npm.noarch 0:1.2.17-5.el6 will be updated
---> Package npm.noarch 0:1.3.3-1.el6 will be an update
--> Running transaction check
---> Package libmodplug.x86_64 0:0.8.7-1.el6.rf will be updated
---> Package libmodplug.x86_64 1:0.8.8.3-2.el6 will be an update
--> Running transaction check
---> Package npm.noarch 0:1.2.17-5.el6 will be updated
---> Package npm.noarch 0:1.3.3-1.el6 will be an update
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    1:libmodplug-0.8.8.3-2.el6.x86_64 from epel

Dependencies Resolved

============================================================================================================================================================================================================================================
 Package                                                   Arch                                                  Version                                                          Repository                                           Size
============================================================================================================================================================================================================================================
Updating:
 npm                                                       noarch                                                1.3.3-1.el6                                                      epel                                                351 k
Skipped (dependency problems):
 libmodplug                                                x86_64                                                1:0.8.8.3-2.el6                                                  epel                                                158 k

Transaction Summary
============================================================================================================================================================================================================================================
Upgrade       1 Package(s)

Total download size: 351 k
Is this ok [y/N]: y
Downloading Packages:
npm-1.3.3-1.el6.noarch.rpm                                                                                                                                                                                           | 351 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : npm-1.3.3-1.el6.noarch                                                                                                                                                                                                   1/2 
Error unpacking rpm package npm-1.3.3-1.el6.noarch
error: unpacking of archive failed on file /usr/lib/node_modules/npm/man: cpio: rename
  Verifying  : npm-1.3.3-1.el6.noarch                                                                                                                                                                                                   1/2 
npm-1.2.17-5.el6.noarch was supposed to be removed but is not!
  Verifying  : npm-1.2.17-5.el6.noarch                                                                                                                                                                                                  2/2 

Skipped (dependency problems):
  libmodplug.x86_64 1:0.8.8.3-2.el6                                                                                                                                                                                                         

Failed:
  npm.noarch 0:1.2.17-5.el6                                                                                             npm.noarch 0:1.3.3-1.el6                                                                                            

Complete!
[alexus@wcmisdlin02 ~]$ 

I'm trying to figure out how to reach out to package maintainer to let him/her know about it and I'm having problem doing so, can someone help?

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

I had have the same update problem with the npm EPEL package, see the error message at the end.

My solution was to remove the 'npm' package and install it again. This was no problem on my server because npm is "just" the package manager of nodejs. The installed npm-packages, handlebars and less, stayed on the server :-)

[root@somewhere yum.repos.d] # yum update
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                                                              |  23 kB     00:00     
 * epel: ftp.uni-koeln.de
base                                                                                                                                                       | 3.7 kB     00:00     
extras                                                                                                                                                     | 3.4 kB     00:00     
updates                                                                                                                                                    | 3.4 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package npm.noarch 0:1.2.17-5.el6 will be updated
---> Package npm.noarch 0:1.3.3-1.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================================================================
 Package                                Arch                                      Version                                           Repository                               Size
==================================================================================================================================================================================
Updating:
 npm                                    noarch                                    1.3.3-1.el6                                       epel                                    351 k

Transaction Summary
==================================================================================================================================================================================
Upgrade       1 Package(s)

Total download size: 351 k
Is this ok [y/N]: y
Downloading Packages:
npm-1.3.3-1.el6.noarch.rpm                                                                                                                                 | 351 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : npm-1.3.3-1.el6.noarch                                                                                                                                         1/2 
Error unpacking rpm package npm-1.3.3-1.el6.noarch
error: unpacking of archive failed on file /usr/lib/node_modules/npm/man: cpio: rename
  Verifying  : npm-1.3.3-1.el6.noarch                                                                                                                                         1/2 
npm-1.2.17-5.el6.noarch was supposed to be removed but is not!
  Verifying  : npm-1.2.17-5.el6.noarch                                                                                                                                        2/2 

Failed:
  npm.noarch 0:1.2.17-5.el6                                                                npm.noarch 0:1.3.3-1.el6                                                               

Complete!

[root@somewhere yum.repos.d]# yum remove npm
Loaded plugins: fastestmirror, priorities
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package npm.noarch 0:1.2.17-5.el6 will be erased
--> Finished Dependency Resolution
base                                                                                                                                                       | 3.7 kB     00:00     
epel/metalink                                                                                                                                              |  23 kB     00:00     
extras                                                                                                                                                     | 3.4 kB     00:00     
updates                                                                                                                                                    | 3.4 kB     00:00     

Dependencies Resolved

==================================================================================================================================================================================
 Package                                Arch                                      Version                                          Repository                                Size
==================================================================================================================================================================================
Removing:
 npm                                    noarch                                    1.2.17-5.el6                                     @epel                                    951 k

Transaction Summary
==================================================================================================================================================================================
Remove        1 Package(s)

Installed size: 951 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing    : npm-1.2.17-5.el6.noarch                                                                                                                                        1/1 
  Verifying  : npm-1.2.17-5.el6.noarch                                                                                                                                        1/1 

Removed:
  npm.noarch 0:1.2.17-5.el6                                                                                                                                                       

Complete!
[root@somewhere yum.repos.d]# yum install  npm
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
epel/metalink                                                                                                                                              |  23 kB     00:00     
 * epel: ftp.uni-koeln.de
base                                                                                                                                                       | 3.7 kB     00:00     
extras                                                                                                                                                     | 3.4 kB     00:00     
updates                                                                                                                                                    | 3.4 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package npm.noarch 0:1.3.3-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================================================================
 Package                                Arch                                      Version                                           Repository                               Size
==================================================================================================================================================================================
Installing:
 npm                                    noarch                                    1.3.3-1.el6                                       epel                                    351 k

Transaction Summary
==================================================================================================================================================================================
Install       1 Package(s)

Total download size: 351 k
Installed size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
npm-1.3.3-1.el6.noarch.rpm                                                                                                                                 | 351 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : npm-1.3.3-1.el6.noarch                                                                                                                                         1/1 
  Verifying  : npm-1.3.3-1.el6.noarch                                                                                                                                         1/1 

Installed:
  npm.noarch 0:1.3.3-1.el6                                                                                                                                                        

Complete!

[root@somewhere yum.repos.d] # /usr/bin/lessc 
lessc: no input files

usage: lessc [option option=parameter ...] <source> [destination]

If source is set to `-' (dash or hyphen-minus), input is read from stdin.

options:
  -h, --help              Print help (this message) and exit.
  --include-path          Set include paths. Separated by `:'. Use `;' on Windows.
  --no-color              Disable colorized output.
  -s, --silent            Suppress output of error messages.
  --strict-imports        Force evaluation of imports.
  --verbose               Be verbose.
  -v, --version           Print version number and exit.
  -x, --compress          Compress output by removing some whitespaces.
  --yui-compress          Compress output using ycssmin
  -O0, -O1, -O2           Set the parser's optimization level. The lower
                          the number, the less nodes it will create in the
                          tree. This could matter for debugging, or if you
                          want to access the individual nodes in the tree.
  --line-numbers=TYPE     Outputs filename and line numbers.
                          TYPE can be either 'comments', which will output
                          the debug info within comments, 'mediaquery'
                          that will output the information within a fake
                          media query which is compatible with the SASS
                          format, and 'all' which will do both.
  -rp, --rootpath         Set rootpath for url rewriting in relative imports and urls.
                          Works with or withour the relative-urls option.
  -ru, --relative-urls    re-write relative urls to the base less file.
share|improve this answer
add comment

Actually, it looks more to me like the libmodplug package from RepoForge might be interfering somehow. I can't say for certain without manually following dependency links, but I would try removing either the libmodplug package currently installed or the repoforge (rf) repository definition and reissue the update command. Take further action (or not) based on the results of that test.

share|improve this answer
    
Yeah. It certainly sounds like you might want to pin libmodplug to rf for the moment since your gstreamer package from rf is what needs it. –  Etan Reisner Aug 5 '13 at 17:50
    
John, How are you seeing that it's from "RepoForge" (I don't think I even have on my system), unless you're referring to rpmforge (which I do have it), from output that I posted in a question it seems like that it's coming from epel though. I can issue --disablerepo=epel then I dont see any errors as it skips whole update entirely (since both of packages are from epel), but removing package, how does it actually help me? –  alexus Aug 5 '13 at 20:14
    
Yes, sorry, "repoforge" is supposed to be "rpmforge". I'm always getting that name wrong. I can see it from rf by seeing the 'rf' string at the end of the package name/version string: e.g. 0:0.8.7-1.el6.rf for libmodplug. I would try --disablerepo=rf instead of --disablerepo=epel. By removing the package instead, it may allow the deps to be resolved entirely within EPEL, not going to RF. –  John Aug 6 '13 at 0:15
    
This is the correct answer, I get the same thing when updating VLC on an EL6 box. I have a bunch of excludes like libmodplug* in each repo file. It took a while to figure out what to exclude, but a yum update now works every time. –  suprjami Aug 13 '13 at 11:27
add comment

John has your answer, I think; you probably have a conflict with a package from another third-party repository.

Regarding your question about EPEL: The EPEL FAQ tells you where to find support or file bug reports for EPEL packages:

Where can I find help or report issues?

You can find help or discuss issues in the epel-devel-list or #epel Freenode IRC channel. Report issues against EPEL to via bugzilla.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.