Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

my connection to pptp gets terminated when I try to do a speedtest on speedtest.net

I have a vps account with centos 5 installed. It uses openvz for virtualization.

on /var/logs/messages the error says:

Aug  5 22:44:24 vps1 pptpd[902]: CTRL: Client x.x.x.x control connection started
Aug  5 22:44:24 vps1 pptpd[902]: CTRL: Starting call (launching pppd, opening GRE)
Aug  5 22:44:24 vps1 pppd[903]: Plugin /usr/lib64/pptpd/pptpd-logwtmp.so loaded.
Aug  5 22:44:24 vps1 pppd[903]: pppd 2.4.4 started by root, uid 0
Aug  5 22:44:24 vps1 pppd[903]: Using interface ppp0
Aug  5 22:44:24 vps1 pppd[903]: Connect: ppp0 <--> /dev/pts/1
Aug  5 22:44:27 vps1 pptpd[902]: CTRL: Ignored a SET LINK INFO packet with real ACCMs!
Aug  5 22:44:28 vps1 pppd[903]: MPPE 128-bit stateless compression enabled
Aug  5 22:44:29 vps1 pppd[903]: Cannot determine ethernet address for proxy ARP
Aug  5 22:44:29 vps1 pppd[903]: local  IP address 192.168.0.1
Aug  5 22:44:29 vps1 pppd[903]: remote IP address 192.168.0.101
Aug  5 22:44:35 vps1 pptpd[902]: GRE: read(fd=7,buffer=6097c0,len=8260) from network failed: status = -1 error = Protocol not available
Aug  5 22:44:35 vps1 pptpd[902]: CTRL: GRE read or PTY write failed (gre,pty)=(7,6)
Aug  5 22:44:35 vps1 pppd[903]: Modem hangup
Aug  5 22:44:35 vps1 pppd[903]: Connect time 0.1 minutes.
Aug  5 22:44:35 vps1 pppd[903]: Sent 134752 bytes, received 20812 bytes.
Aug  5 22:44:35 vps1 pppd[903]: MPPE disabled
Aug  5 22:44:35 vps1 pppd[903]: Connection terminated.
Aug  5 22:44:35 vps1 pppd[903]: Exit.
Aug  5 22:44:35 vps1 pptpd[902]: CTRL: Client x.x.x.x control connection finished

I followed the instructions here on installing pptp

and this question is connected to How do I add eth0 on centos 5 that is using openvz

the question is: how do I make that speedtest page work?

share|improve this question

1 Answer 1

The problem can be either on the host or one the client side. Make sure port 1723 and protocol 47 are allowed on both sides.

share|improve this answer
    
my iptables rules are here: serverfault.com/questions/528815/… i do believe 1723 is open. dont know how to check port 47 is though –  reikyoushin Aug 5 '13 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.