Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Ubuntu LTS and I'm getting errors when trying to do some of my pip install stuff, like scrapy for example. This is the error I get:

Unable to execute gcc: No such file or directory
Error: command 'gcc' failed with exit status 1

I'm installing pip within a virtualenv. I tried to install build essentials with the following command but I still get the same error:

apt-get -y install build-essential

Can anyone help me understand where I have gone wrong please?

EDIT - A bit more information:

ubuntu@ip-10-164-8-155:/var/log$ gcc -v
The program 'gcc' can be found in the following packages:
 * gcc
 * pentium-builder
Try: sudo apt-get install <selected package>
share|improve this question
    
What was the output of your apt-get -y install build-essential? You definitely do not have the gcc executable installed. –  Alex G Aug 5 '13 at 23:57
add comment

1 Answer

up vote 2 down vote accepted

NOTE: from your gcc -v output Try: sudo apt-get install

sudo apt-get install gcc

share|improve this answer
    
That message indicates that the command (gcc) wasn't found, but that Ubuntu can suggest a package that provides it (the gcc package in this case). –  chrylis Aug 6 '13 at 2:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.