Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an issue with an application I've been developing that makes web requests over SSL to a local server VM with IIS 8 installed (Windows Server 2012).

So far all the other requests in the application are working apart from one on an XP VM.

It's XP SP3 x86 machine with all the updates installed.

The error I'm getting is The message or signature supplied for verification has been altered, this in turn is causing a failure in decryption and my report fails to load.

This works fine on other operating systems, I have Windows 7 N Professional and Home Premium VMs (both x64) which work fine.

I found this article which mentioned uninstalling KB968389, which I did to no effect.

I did also see something about possible unsupported encryption methods (AES), could this be my issue?

I'm used to doing basic IIS and Server Management as well as debugging, unfortunately I have no idea which method of encryption is being used or how to find out.

If that's not the issue, what else could it be?

share|improve this question
    
Are you using SNI to use multiple SSL sites on the same IP on the server? –  Peter Hahndorf Aug 6 '13 at 17:57
    
The SNI box isn't ticked but there are two SSL sites on the same server. I did change one to bind just to the IP with no host header and the other one has a host header. –  Sean Aug 7 '13 at 8:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.