Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running Apache on Ubuntu Precise, with PHP 5.5

Trying to access my var/www/ gives me a 500.

/var/log/apache2/error.log

shows:

/var/www/web/.htaccess: <IfModule not allowed here

my .htacess is :

DirectoryIndex app.php


<IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{REQUEST_URI}::$1 ^(/.+)/(.*)::\2$
    RewriteRule ^(.*) - [E=BASE:%1]

    RewriteCond %{ENV:REDIRECT_STATUS} ^$
    RewriteRule ^app\.php(/(.*)|$) %{ENV:BASE}/$2 [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule .? - [L]

    RewriteRule .? %{ENV:BASE}/app.php [L]
</IfModule>

<IfModule !mod_rewrite.c>
    <IfModule mod_alias.c>       
        RedirectMatch 302 ^/$ /app.php/       
    </IfModule>
</IfModule>

Into my apache.conf I added:

<Directory />
AllowOverride ALL
</Directory>

But still same error.

share|improve this question

1 Answer 1

up vote 6 down vote accepted

You need to configure your apache to enable configuration from the .htaccess file. So in the directory section be sure you have the option

Allowoverride ALL 

for more information more information about allowoverride.

In your setup if you use only mod_rewrite maybe you can set only FileInfo , I always set the Options parameter to SymLinksIfOwnerMatch to be able to perform redirection to other sites.

Allowoverride FileInfo 
Options SymLinksIfOwnerMatch

I hope it will help, if you already set this configuration please add information with your virtualhost configuration.

share|improve this answer
    
This is a fresh install of Apache. I have no <Directory /> section in apache2.conf. I've added my update above. Thanks –  Kiksy Aug 6 '13 at 13:18
    
I forgot to restart Apache. Thats working now . –  Kiksy Aug 6 '13 at 13:30
    
On my end I had a missing Directory directive. Once added, it worked properly. I suppose this is new in version 2.4 of Apache because it used to work with 2.2... –  Alexis Wilke Feb 24 at 9:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.