Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i am expecting a very curious problem. In a script collecting disk infos on a list of W2008 servers, i realize that, for some servers, the Wmi info for the disk size is wrong.

My Powershell command: Get-WmiObject win32_LogicalDisk. For one partition, it returns 70Go of disk size, but 100 Go of FreeSpace... When i right-click the partition in the explorer, the disk size is 70Go, and the Freespace is 69,5Go. But... in the Disk Management, the partition size is 102Go... Maybe there is a problem with the performance counters but i don't know what to do...

What i have tried:

  • get disk info via wmi, fsutil and "explorer" : wrong infos.
  • get disk info via Disk Management, and the diskpart utility : good infos.

  • chkdsk /x q: : no changes.

  • with dispart.exe, on the volume Q: : extend filesystem. No changes.
  • Reset the performance counters.

Any idea?

Some screen captures:

enter image description here enter image description here

share|improve this question
Please include links to screenshots of the Explorer and disk management windows. – longneck Aug 7 '13 at 12:34
Thanks, i add screen captures. – plunkets Aug 23 '13 at 14:34
Make sure you have backups of any data on the drive. Then run chkdsk /x Q: and see if that resolves the issue. – Chris S Aug 23 '13 at 14:51
I've tried chkdsk but nothing changes. I also tried the diskpart.exe utility with the extend filesystem command. Nothing. – plunkets Aug 23 '13 at 15:59
Have a look at this blog article and see if it helps you out:… – TheCleaner Aug 26 '13 at 13:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.