Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to figure how to view the console of a Fedora linux server by using vnc. In other words, I'm trying to see what a user normally sees as if they were physically sitting in front of the computer. As of now, I ssh in and run /usr/bin/vncserver, it seems to be starting ok.

in the log file I have

vnc log show only:

Xvnc version 4.0 - built Jan 8 2005 16:57:17
Underlying X server release 60700000, The X.Org Foundation

error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!

When I use a vncviewer from windows and do :3, it gives me X with a cmdline which doesn't really help me. I need to see what is on the console so I can see the menu options running on it. Any ideas how i can do this?

Update: When I run

startkde &

I get the following:

[1] 4144 root@server1 .vnc]# which: no fs in ('usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin) /usr/binstartkde: line 16: [: argument expected Note enough free disk space on /tmp

startgnome just gives me a command not found error..

share|improve this question

3 Answers 3

You need x11vnc to see the console session in VNC.

Though it sounds like you're not actually trying to view the console session on the computer, which is the session the local user is seeing when they sit at the computer. It sounds like you need a desktop environment. To get this, look into your ~/.vnc/xstartup file and add the command to start up the WDE you want when you start a VNC session, such as startkde & or startgnome &.

A step further, ditch VNC altogether and set up FreeNX and use NoMachine's client to connect to it. FreeNX is much better than VNC all around.

share|improve this answer
    
x11vnc is good for allowing a vnc client to connect to the running (non-VNC) X server after the fact. An alternative if you're running Red Hat/Centos/Fedora would be the vino packages. It does essentially the same thing. Finally, you could also add the vnc.so plugins for X but that has to be done from the start (eg, be in the configuration before X starts up). While NX may be better for some things, it doesn't necessarily help the original poster in this case. –  Travis Campbell Aug 11 '09 at 21:00
    
No, I am trying to view the console session on the computer. I'll check out the startup file –  phill Aug 11 '09 at 22:08
    
startgnome & should be startx &. My mistake. Also check here for full contents of the xstartup file: skullbox.net/vncserver.php –  churnd Aug 12 '09 at 10:57

I am unsure what you mean by "console". If you mean your graphical desktop read this section of the fedora docs (in short: System > Preferences > Remote Desktop).

If you want to see a text "console" then you should look at ssh.

share|improve this answer

If you are trying to interact with the same session as the user at the console screen, install vino and make sure the user uses gnome. Then have the user enable desktop sharing in the gnome preferences. You can then connect to the console using VNC. By default there is no password, but the user must ack your request each time. The user can set up a password and disable the pop-up if that is what you want. You can then go home and reach your console at work through vnc as long as you don't log out the console session.

Just a legal note. Enabling vnc connections to the user's sessions without that pop-up that lets the user accept or deny may be illegal in some countries. You are warned. Of course the user may elect to disable it, but I would not roll out a configuration that turns off the pop-up.

You can also set up vncserver to offer you 'virtual' graphical sessions on a server that don't have any relation to the servers physical console. Install the tigervnc-server package, edit /etc/sysconfig/vncservers, chkconfig vncserver on, service vncserver start

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.