Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a new Windows Server 2003 machine I'm trying to configure as a DNS server and Domain Controller.

Whenever I add an XP client to the domain I get the following event log error on boot up: "Windows cannot determine the user or computer name. (The RPC server is unavailible). Group Policy processing aborted."

This seems to be because it can't resolve the fully qualified domain name of the domain controller. I can ping the domain controller. Then I try to ping it's fully qualified domain name and it fails. Then I try to ping the fully qualified domain name with a . at the end and it succeeds. Now all attempts to ping it's fully qualified domain name succeed (until I reboot). (see below)

I can work around this by adding a host file entry mapping the IP to the fully qualified domain name but I'd like to avoid that hack if I can.

Any thoughts? Thanks.

What follows is the attempt to resolve the domain controller from a XP machine on the domain (where dc-server is the domain controller):

C:\>nslookup dc-server
Server:  dc-server.localdomain.org
Address:  192.168.42.2

Name:    dc-server.localdomain.org
Address:  192.168.42.2


C:\>nslookup dc-server.localdomain.org
Server:  dc-server.localdomain.org
Address:  192.168.42.2

Name:    dc-server.localdomain.org
Address:  192.168.42.2


C:\>ping dc-server
Pinging dc-server [192.168.42.2] with 32 bytes of data:
Reply from 192.168.42.2: bytes=32 time=1ms TTL=128

C:\>ping dc-server.localdomain.org
Ping request could not find host dc-server.localdomain.org. Please check the name
 and try again.

C:\>ping dc-server.localdomain.org.
Pinging dc-server.localdomain.org [192.168.42.2] with 32 bytes of data:
Reply from 192.168.42.2: bytes=32 time=1ms TTL=128

C:\>ping dc-server.localdomain.org
Pinging dc-server.localdomain.org [192.168.42.2] with 32 bytes of data:
Reply from 192.168.42.2: bytes=32 time=1ms TTL=128

ipconfig /all on the client follows:

C:\>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : LMCA8-E03
        Primary Dns Suffix  . . . . . . . : LOCALDOMAIN.ORG
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : LOCALDOMAIN.ORG

Ethernet adapter Wireless Network Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Dell Wireless 1397 WLAN Mini-Card
        Physical Address. . . . . . . . . : 00-22-5F-61-F5-08

Ethernet adapter Local Area Connection 2:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Con
nection
        Physical Address. . . . . . . . . : 00-21-70-DE-43-69
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.42.13
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.42.1
        DNS Servers . . . . . . . . . . . : 192.168.42.2
share|improve this question
    
Can you post a dump of your forward zone, so that we can see if you are missing glue records, etc.? –  Avery Payne Aug 13 '09 at 13:39
    
Please post the output of "ipconfig /all" on dc-server. –  alexy Aug 14 '09 at 7:45
    
I'm giving you a +1 simply because you're using subnet 192.168.42. That's my favorite subnet, too :-) –  Massimo Sep 2 '09 at 11:10

7 Answers 7

Run dcdiag (dcdiag /q -show errors; dcdiag /fix - fix problems)

share|improve this answer
    
May be trouble in zone (.) in DNS? –  cherniaev Aug 14 '09 at 5:00

are you actually using localdomain.org or are you using that as an example? If you are using localdomain.org problems would arise depending on how you DNS search order is set up on your machines, including the domain controller itself.

You'll also need to ensure that your DNS server has reverse lookup zones as well as forward lookup zones. You may want to consider doing DHCP, with your domain controller as the primary dns, and your other dns as your secondary, then in your windows DNS add forwarders to your DNS server's properties.

share|improve this answer
    
Thanks for the reply. I am not using localdomain.org I did a replace as I posted as I did not want to post our internal info, but the only DNS server I've told the XP client about is 192.168.42.2 (the DNS/domain controller server). It's set as the Preferred DNS Server. –  Chris S. Aug 11 '09 at 23:31
    
As far as the lookup zones go on the DNS server I've added one Reverse Lookup Zone for the 192.168.42.x Subnet. Are there any others that are needed. In this lookup zone I can see PTRs for each PC in the domain. Each entry maps a 192.168.42.x address to a hostname of the form "[hostname].localdomain.org.". –  Chris S. Aug 11 '09 at 23:33
    
You can try repairing windows DNS if you have the windows install disc handy. Can you list your forward lookup zones? you should have at least two, and if you have a "." zone, you must delete it, as you do not want to configure your windows DNS server as a root server, which could cause the problems you're experiencing. –  IceMage Aug 14 '09 at 15:03
    
also, try posting an ipconfig /displaydns for everyone if you don't mint? –  IceMage Aug 14 '09 at 15:04

Are there by chance multiple adapters on the client or server?

share|improve this answer
    
The server only has one network connection. The client has two, a wired and a wireless, but the wireless is disabled. –  Chris S. Aug 12 '09 at 15:13

Update: I wouldn't think that this is suppose to be an issue. But maybe the capital letters in the dns suffix are the problem. Try changing that ( in the dhcp or on the local machine).

Before update: Can you please post the output of ipconfig /all on one of the xp clients.

Specially the:"DNS Suffix Search List".

share|improve this answer
    
With ipconfig /all, I get: DNS Suffix Search List. . . . . . : LOCALDOMAIN.ORG –  Chris S. Aug 11 '09 at 21:25
    
The rest of the output of ipconfig /all is tough to put meaningfully into 600 unformated characters. Any other items that might shed some light on this? –  Chris S. Aug 11 '09 at 21:29
    
You can add it to your question (click "edit") –  Michael Haren Aug 12 '09 at 0:36
    
Thanks, ipconfig added to the question. –  Chris S. Aug 12 '09 at 15:16
    
Thanks for the advice. It's an interesting thought. I went into the DNS settings on the XP client and specified the lowercase DNS suffix. Unfortunately the problem remained after a reboot. I also tired adding the suffix "[lowercase dns suffix]." to the list of DNS suffixes. Unfortunately this didn't work either. –  Chris S. Aug 12 '09 at 20:15

One little note: the nslookup command will use a separate sequence to resolve names than the ping command. nslookup will only resolve using the configured DNS server. Use the "server" command under the nslookup ">" prompt to see and change the actual server IP address.

On the other hand, the ping command will try to resolve the hostname to an IP address using other means first, such as the c:\windows\system32=drivers\etc\hosts fil, a possible WINS and Windows AD domain controller, and then will try to resolve using the actual registered DNS server. The actual sequence may vary, depending on your registry or other settings you may have.

share|improve this answer

Maybe you have a host file somewhere that's screwing this up?

share|improve this answer

Ensure that you have Reverse lookup zones for each subnet, or at least for the subnet that you are trying to get the FQDN for.

Also check that your Forward zone isn't dc-server.localdomain.org. with the period actually there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.