Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On a CentOS 6.4 running linux server, I am trying to rsync a folder with strato hidrive (http://www.strato-hosting.co.uk/online-storage-hidrive/advanced/). The server is running rsync version 3.0.9.

What I have done to set up the rsync to the hidrive:

  1. Generated a rsa key that needs to be uploaded to strato using the following command: ssh-keygen -f /root/.ssh/id_rsa -t rsa -N ''
  2. Saved the id_rsa.pub file to my local machine so that I could upload it in the strato hidrive controlpanel, when I upload it, it does say that it recognizes that it is a rsa key.
  3. I've done a test to see if it works using the following command: /opt/rsync/bin/rsync -av -e 'ssh' --rsh="ssh -p22" /home/user/example/ mystratousername@rsync.hidrive.strato.com:/users/mystratousername/

Normally it would just rsync, but now it asks for a password (while I didn't use a passphrase). I do have this working on 5 other machine's but I set that up like half a year ago.

share|improve this question
    
No answer for your question, but the -e and --rsh options are the same, so you can remove one of them. Additionally, ssh and port 22 should be the default values, so you can remove both: /opt/rsync/bin/rsync -av /home/user/example/ mystratousername@rsync.hidrive.strato.com:/users/mystratousername/ –  etagenklo Aug 8 '13 at 15:13
    
BTW, what happens when you specify the id_file with -i option? /opt/rsync/bin/rsync -av /home/user/example/ --rsh="ssh -p22 -i "/root/.ssh/id_rsa" mystratousername@rsync.hidrive.strato.com:/users/mystratousername/ –  etagenklo Aug 8 '13 at 15:18
    
I did try that, it made no difference. I did solve my problem, it is probably a key length requirement on the strato hidrive. See my answer for more information. –  jeffreydev Aug 9 '13 at 9:17

1 Answer 1

up vote 0 down vote accepted

The problem was in the id_rsa.pub key-length, apparently the default bit length of the key was different than the default 2048 (like on the other server), so when I regenerated the key using -b 2048 it did work for me. Do note, this is probably only because of strato hidrive requirements.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.